After updating my TomTom, all the speed cameras are deleted — TomTom Community

After updating my TomTom, all the speed cameras are deleted

EnBaxEnBax Posts: 5 [Apprentice Traveler]
edited February 10 in Speed Cameras
I just "updated" my TomTom, and they deleted all the speed cameras. Is this acceptable? As far as I'm concerned, I bought it with the speed camera information it came with. Updating something doesn't usually involve making it worse. Does anyone know a way of getting in touch with them, please?

Best Answer

Answers

  • YamFazManYamFazMan Posts: 18,680
    Superusers
    Accepted Answer
    HI
    @EnBax
    Welcome to the site....
    There has been a change in the Speed cam subscriptions... The Tomtom subscriptions now 'Auto Renew' by default....

    Note... If your subscription has expired you will NOT get any Speed cam warning on the device, even the old database is still installed on the device....

    See T&C's 4.2 Subscriptions, renewals and Free Trials...
    Here... https://www.tomtom.com/en_gb/legal/terms-and-conditions/#4YourAccountandyoursubscriptions

    Tomtom Speed Cam FAQ….
    See... https://help.tomtom.com/hc/en-gb/articles/360015806999
    _________________________
    _________________________

    Contacting Tomtom Support….
    Due to COVID-19 the phone service has been suspended
    For Tomtom Support Email or Chat lines...
    (Monday to Friday Normal Office Hours)

    The way of contacting Customer Services has changed

    (1)... A couple of Tips when Contacting Tomtom Support....
    Here... https://discussions.tomtom.com/en/discussion/comment/1714844/#Comment_1714844
    _________________________

    (2)... Tomtom FAQ … How to Contact Tomtom Support....
    Here… https://help.tomtom.com/hc/en-gb/articles/360015568919-How-to-contact-TomTom-support

    Stay Safe... ATB YFM
  • EnBaxEnBax Posts: 5 [Apprentice Traveler]
    Thanks YamFazMan, very helpful.

    It seems pretty sharp practice on TomTom's part though.
  • PTuckerPTucker Posts: 3 [Apprentice Seeker]
    I've got the same problem, I paid for and updated the speed cameras and they've all gone! Disappeared completely, I can see them out of my window but nothing on the Tomtom, no red light cameras, fixed cameras, average speed zones, nothing. This isn't good enough for a paid service which I've been using for several years now. How do I get them back or load an older version of the cameras file?
  • DougLapDougLap Posts: 7,201
    Superuser
    Hi @PTucker

    It appears that during the current situation with so many working from home that If you have bought a new cameras subscription recently it may not have been allocated to your account yet. I suggest that you contact Customer Support via Chat on Monday and they should be able to sort it whilst you are on.

    Tap Support at the top of this page
    Sign in Top Right of next Page. (you have to do this)
    When signed in Tap Contact Us bottom right
    Help Box appears and after a few seconds Get in Touch also appears
    Tap Get in Touch
    You are now offered Chat or Email. If Chat is closed it will tell you the hours that it will be available.

    Chat is busy you may have to try a few times.

    If you have any difficulty try another web browser as that sometimes helps.

    Doug
  • PTuckerPTucker Posts: 3 [Apprentice Seeker]
    I'm not working from home, I'm a delivery driver so camera updates are important to me and I've been subscribing for a while now, the only thing that's changed recently is the payment method. I can update cameras from MyDrive Connect and it downloads the file to my Via52 (9kB at the last count) and it's showing as subscribed, but it's like an empty file, that's my issue, there's nothing showing when I know cameras are there. I want the cameras on my SatNav seeing as I pay for them but I'm not getting the service anymore, it was alright until a week ago. I think the fault lies with Tomtom not my system and I'd like it fixed, it seems I'm not the only one with this problem either, just see the posts on here.

    So far Tomtom support seems very lacking in support atm, my job means I can't contact them during office hours very easily as I'm driving from before they start 'til after they're finished and the chat bot is as much use as a motorcycle ashtray, no help at all. I'm not a happy customer (as I'm sure you've guessed by now).

    It needs sorting asap!
  • DougLapDougLap Posts: 7,201
    Superuser
    Hi @PTucker

    Lets see if @VikramK , one of the mods, is able to help having looked at your units settings on the Tomtom Servers on Monday. Look back then.

    Doug
Sign In or Register to comment.

Who's Online in this Category0