Missing speed cameras after update since Xmas 2020

CaroK
CaroK Registered Users Posts: 4
Apprentice Seeker
edited February 2021 in TomTom Services
Hi, has anyone else noticed speedcameras missing after latest biggest updates? I drove around and almost 70% of cameras on my route were missing and no warning was sounded on them? Unfortunately i bought this tomtom device on which i cannot do any changes on maps and so fustrating to do them in website.

Has maybe someone done job and managed to remove cameras by mapshare corrections? Is that possible?

Western Finland, Seinajoki (and 150 km range from here atleast)

Comments

  • rider1rider
    rider1rider Registered Users Posts: 1,417
    Exalted Pioneer
    do you have service for speed cam active?
    factory reset??
  • Lochfrass
    Lochfrass Posts: 17,757
    Superuser
    It also makes sense to specify which device you have at all. Maybe reinstalling the cameras will do the trick. However, you first need to know which device you have.
  • CaroK
    CaroK Registered Users Posts: 4
    Apprentice Seeker
    I have 2 different tomtoms (50 & 20) at home, both services activated yearly and last time before xmas update. Both are missing cameras, and no notification is sounded when you drive close to camera that has been on same place over 10 years.

    Before that update a yearly order renewing both worked just fine.
  • Lochfrass
    Lochfrass Posts: 17,757
    Superuser
    I would try reinstalling the cameras.
    If that doesn't help, support should be able to help you check the camera data in your account.
  • CaroK
    CaroK Registered Users Posts: 4
    Apprentice Seeker
    edited February 2021
    Where do i contact support?

    How come both my devices, tt 20 is on my dads car, have same problem?

    edit, did manufacture reset, removed cameras and now uploaded them again. To bad closest camera not working is 45 km away so cannot test very soon..
  • DougLap
    DougLap Posts: 9,844
    Superuser
    Hi @CaroK

    Can you create a route on the unit starting and finishing either side of the cameras and then run a Preview of the Route. This will show if it will announce cameras.

    Doug
  • YamFazMan
    YamFazMan Posts: 20,814
    Superuser
    Hi
    @CaroK
    Welcome to the site....
    Check... Tap 4Dot (.... Menu)
    Are any 'Sound Icons' slashed through ??? It’s really easy to turn off a Sound Icon when swiping through the Menus

    v412wdu3g07c.jpg

    Stay Safe... ATB YFM
  • Lochfrass
    Lochfrass Posts: 17,757
    Superuser
    CaroK wrote: »
    Where do i contact support?

    Have a look at this:
    https://discussions.tomtom.com/en/discussion/comment/1714844/#Comment_1714844
  • CaroK
    CaroK Registered Users Posts: 4
    Apprentice Seeker
    YamFazMan wrote: »
    Hi
    @CaroK
    Welcome to the site....
    Check... Tap 4Dot (.... Menu)
    Are any 'Sound Icons' slashed through ??? It’s really easy to turn off a Sound Icon when swiping through the Menus

    Stay Safe... ATB YFM
    I have all notifications on. As i told, 70% of cameras can be passed without warning. And it started after i payd for renewing my yearly order and dowloaded new cameras. Suddenly it stopped alarming. Still some cameras make alarm. So no image or sound of upcoming camera. Nothing, just blank road.