No Radio display in TomTom Carminat Renault Clio 2010 — TomTom Community

No Radio display in TomTom Carminat Renault Clio 2010

Fel17Fel17 Posts: 10 [Apprentice Seeker]
edited February 8 in Built in car navigation
Hello out there,

I just purchased a Renault CLIO 3 with built in TOMTOM Carminat, and it seems like suddently, i have lost all of my RADIO Display. Which means, i can not see anything related to it. No Settings, No volume, no frequencies, no Phone, no equializer...NOTHING.

I have tried updating the software using TOMTOM Home but it still doesnt work. I would be very thankfull if a moderator or someone with the same problem could help me. My device is IAxxxxJxxxxx

Mod edit: Personal information edited!

Answers

  • Fel17Fel17 Posts: 10 [Apprentice Seeker]
    Hello Mate, thanks for your answer. I have follow all the steps and reinstalled the TOMTOM in my car. Sadly, the radio controls are still lost.

    Is there maybe any other suggestion or solution out there?

    Thank you in advance.
  • JonfrigJonfrig Posts: 5 [Apprentice Traveler]
    Fel17 wrote: »
    Hello Mate, thanks for your answer. I have follow all the steps and reinstalled the TOMTOM in my car. Sadly, the radio controls are still lost.

    Is there maybe any other suggestion or solution out there?

    Thank you in advance.

    Hi Fel17!
    I'm having the same trouble with my carminat in my megane, have you gotten it fixed? If so, what was the solution?
  • AngryBirdAngryBird Posts: 57 [Supreme Trailblazer]
    Needs renault clip and autoconfiguration to be run. Can't be resolved with TomTom
  • Fel17Fel17 Posts: 10 [Apprentice Seeker]
    Hello, I have found out one solution.
    Apparently sometimes when you update your TomTom, the radio software is no longer compatible and therefore you loose the radio display.

    The solution to this is to bring your car to renault and let them update the radio firmware. I have been by renault and they have told me that that is the normal failure and 90% of the times it works after it. (It cost around 30 minutes of work, should not be very expensive).

    Sadly for me (Clio 3) this was not the case and I am on the other 10%.
    Now I will try to find an older version of the TomTom software and try to reinstall it.

  • AngryBirdAngryBird Posts: 57 [Supreme Trailblazer]
    It has nothing to do with wrong software of TomTom.
    If you were in Northern Ireland I could solve this issue for you in no longer than 30 minutes...
  • Fel17Fel17 Posts: 10 [Apprentice Seeker]
    Could you please explain me what is there to do? Maybe I could tell the renault people exactly what to try.
    It would be very nice, thank you
  • AngryBirdAngryBird Posts: 57 [Supreme Trailblazer]
    Auto-configuration and hard reset of the below with Renault Clip of:
    - SATNAV
    - MIU (BIC)
    - RADIO
  • Fel17Fel17 Posts: 10 [Apprentice Seeker]
    Dear Angrybirrd, thank you for these steps. I have showed this to my Renault handler, and he has told me that, in many cases, after a hard reset of the radio, the radio won't work anymore at all, only extremly quiet sounds using AUX cable.

    Do you have any experiences with these? Have you performed this repair successfully in the past? Have you had the situation that the radio would stop working after it?

    I would really appreciate any information on the subject. Thank you
  • AngryBirdAngryBird Posts: 57 [Supreme Trailblazer]
    Change your dealer then :) If they don't know what to do.
    If radio stops working - means they did something wrong
  • Fel17Fel17 Posts: 10 [Apprentice Seeker]
    Thanks for your comment, however your answer doesn't really help me make a decision.
    Could you answer the questions if you have done this in the past? Is there something special to consider? Have you encountered any problems or issues by doing this?

    Thanks in advance for any help you can provide.
  • Fel17Fel17 Posts: 10 [Apprentice Seeker]
    But also is not only the repair shop where they told me that. This problem also appears in different forums. That is why I ask you for more details.
  • AngryBirdAngryBird Posts: 57 [Supreme Trailblazer]
    @Fel17 I can't make decision instead of you. I did it in the past and I can revive such "dead" radio units as well.
    I can't say anything on behalf of your dealer. They may not be good professionals then or simply don't exactly know how to do things correctly. However they have all information they need to correct the error.

    And most times it happens after you tried "TomPlayer" application.
  • AngryBirdAngryBird Posts: 57 [Supreme Trailblazer]
    @Fel17 Just restored one unit with those symptoms today successfully.
    Also upgraded radio to the latest firmware 91.14 so it is able to work with bluetooth on new phones
  • JamesCroweJamesCrowe Posts: 4 [Master Traveler]
    Big thank you to AngryBird. He sorted out all my problems today. He knows exactly what to do and how to do it. Everything now working as it should be
  • Fel17Fel17 Posts: 10 [Apprentice Seeker]
    @JamesCrowe thanks a lot for your help. Just out of curiosity what problems did you have with your car and what car do you drive. I will definetly try this out next week.
  • JamesCroweJamesCrowe Posts: 4 [Master Traveler]
    2011 Megane coupe.I had no radio display ,and could not pair up my phone. AngryBird met up with me and sorted it all out. True gentleman
  • Fel17Fel17 Posts: 10 [Apprentice Seeker]
    @AngryBird did you only perform the three hard resets you mentioned above? Plus the firmware update? Do you think this will also be possible on my Carmina TomTom Clio 3 2010?
  • AngryBirdAngryBird Posts: 57 [Supreme Trailblazer]
    Fel17 wrote: »
    @AngryBird did you only perform the three hard resets you mentioned above? Plus the firmware update? Do you think this will also be possible on my Carmina TomTom Clio 3 2010?

    1. Update firmware of radio (not necessary)
    2. Autoconfig all three
    3. Hard reset all three
  • Fel17Fel17 Posts: 10 [Apprentice Seeker]
    @AngryBird perfect, thanks a lot. The very last question from my side would be... Is there a specific sequence you have to follow e.g.
    1 satnav
    2 Miu
    3 radio

    Or is it the same if I for example configure the radio first, then satnav and then Miu.
  • AngryBirdAngryBird Posts: 57 [Supreme Trailblazer]
    there is no order required - doesn't matter.
    Basically only autoconfig of satnav and hard reset may help. But no harm in doing all three
Sign In or Register to comment.

Who's Online in this Category1

Lost_Soul
Lost_Soul