Carminat in loop with hourglass

Sam_Lane246 Registered Users Posts: 2
Apprentice Seeker
edited February 2021 in Built in car navigation
I need major help. This is starting to upset me.

About 4-5 months ago I turned on the car and the carminat started up as normal, but then just turned off, started up again, got to the main screen with the map (which wasn't in the right location) and has been stuck in this loop ever since.

Weird thing about it, my phone would still connect to it whilst all this was going on. So I could still answer the phone via bluetooth as well as play music.

I now have a new phone and as the screen/carminat won't stay on long enough for me to pair it.

I have tried a lot of things:
Backing it up - restoring it
removing the loop.dir (I think it was called)
Tried some links I found on another post
Purchasing new maps

None of these have worked. The maps now says "your map has not been updated in 20weeks" when clearly it has.
I am so close to pulling my hair out with this.

Help me Obi - Carminat - Kenobi, you're my only hope.

The car is a 2011 Clio Dyminque sport - if that helps.


  • VikramK
    VikramK Administrators Posts: 13,714
    Hi @Sam_Lane246

    Welcome to the community!
    My recommendation would be to remove the SD card from the device. Format it on a computer - FAT format




    Do a clean re-installation of TomTom HOME. See the article here-


    Note: If the content in the image above is not clearly visible, just right-click on it and open in a new tab/window.

    Regards, Vikram
  • Sam_Lane246
    Sam_Lane246 Registered Users Posts: 2
    Apprentice Seeker
    Hi Vikram,

    I've tried that in my previous attempts and it didn't work. I've tried that a few times.

    I found an article on Tom-tom website about an update before April 2019 which would make the in build navigation not working if it wasn't updated before then. It gave a link but it obviously doesn't lead anywhere anymore.

    The car wasn't used for 3 years and wasn't updated.

    Is there any way to get this update?


This discussion has been closed.