TomTom Traffic on the GO 620 Wi-Fi no longer reports speed camera — TomTom Community

TomTom Traffic on the GO 620 Wi-Fi no longer reports speed camera

Gegi05Gegi05 Posts: 2 [New Seeker]
I HAVE A TOMTOM GO 620 THAT NO LONGER REPORTS THE AUTOVELOX, IT IS 3 YEARS OLD AND AN ANNUAL SUBSCRIPTION IN PROGRESS EVEN IF NOT NECESSARY, WHY DO I NOT SEE THE AUTOVELOX SIGNALS MORE? THE ONLINE ASSISTANCE WAS NOT ABLE TO HELP ME. IS THERE AN ASSISTANCE CENTER IN THE PROVINCE OF VENICE TO CONTACT? THANKS



Mod edit: Machine translated (Italian)

Best Answer

  • DougLapDougLap Posts: 7,228
    Superuser
    Accepted Answer
    Hi @Gegi05

    Maybe @VikramK or @lampard can check the settings on the Tomtom Servers and adjust if required.

    Look back here later to see what they have to say.

    Doug

Answers

  • DougLapDougLap Posts: 7,228
    Superuser
    Accepted Answer
    Hi @Gegi05

    Maybe @VikramK or @lampard can check the settings on the Tomtom Servers and adjust if required.

    Look back here later to see what they have to say.

    Doug
  • Gegi05Gegi05 Posts: 2 [New Seeker]
    Grazie👍
  • VikramKVikramK Posts: 11,140 Moderator
    Hi @Gegi05
    Welcome to the community! The subscription on your TomTom account looks good.
    I would recommend that you do a factory reset and test it when you drive next time on a planned route.

    Main menu- Settings- System- Reset device.

    To avoid losing your stored favourites on the device you can create a back-up using MyDrive..

    See user guide

    Regards, Vikram
Sign In or Register to comment.

Who's Online in this Category0