Go500 doesn't fully start — TomTom Community

Go500 doesn't fully start

ruimauruimau Posts: 5 [Apprentice Seeker]
Hi!

I have been dealing with an issue with my Go 500.

I have updated it. I have used the factory reset.
It says it's udpated but when I start it, it's always with the picture you see here. Then, off, then again same picture. It doesn't go on to the menu.

Anyone can help? It seems reseting doesn't work. And I can't even use the SD card to install the maps because it needs to be done in the device, not in My Connect.

Thank you in advance!

Rui

a2kwiiz5mi3t.jpeg
eexcc84lxp8r.jpeg

Comments

  • VikramKVikramK Posts: 11,411 Moderator
    Hi @ruimau
    Welcome to the community!
    My advice would be to try a recovery mode that will do a clean reinstallation of the firmware. See the steps in the video below-



    Regards, Vikram
  • ruimauruimau Posts: 5 [Apprentice Seeker]
    Thank you Vikram,
    I did that already. Unfortunately it didn't work.
  • DougLapDougLap Posts: 7,600
    Superuser
    Hi @ruimau

    If you have an extra memory in the unit then, if you have a map on the units internal memory, remove the card and try again. If you don't have a map on the internal memory then maybe we can get one of the Mods on here to add a small map so you can try recovering the unit with the extra memory card removed.

    Doug
  • ruimauruimau Posts: 5 [Apprentice Seeker]
    Hello Doug,
    Thank you for your reply. In fact. I had a memory card but was not using it. Now, I tried to do the opposite: to have the big map in the SD card but the message is the same. If I remove the SD card I have no other map now. I have info that I need to reinstall a map. That can be a good thing, right? I will try to install a small map now without the SD card.
    I will come back.
    Thanks!
    Rui
  • ruimauruimau Posts: 5 [Apprentice Seeker]
    Hello again,
    I removed the sd card. Installed a smaller map in the internal memory. reinstalled the system and the pictures are as below.
    lg6xgcaqmna1.png

    then this:
    eunfs6uc9kpd.png

    after:
    elcoev7icqnk.png

    and finally back to this one:
    db829udlx56y.png

    And it keeps on going around and around.

    Any help is appreciated!
    Thanks!
    Rui
  • DougLapDougLap Posts: 7,600
    Superuser
    Hi @ruimau

    Lets see what @VikramK suggests as a next step.

    Doug
  • VikramKVikramK Posts: 11,411 Moderator
    Hi @ruimau

    I asked my team to review the logs in the backend but all looks good from the application side.
    Are you able to access the main menu and perform a factory reset?

    But this is just a try...
    If a factory reset does not work then I would recommend reporting this to our customer service.

    Regards, Vikram
  • ruimauruimau Posts: 5 [Apprentice Seeker]
    Thank you VikramK!
    No, I cannot access the main menu and believe me, I tried! Had the device on for hours :)
    I will reach out to the Customer Service. I only feel they will offer me a new device with a discount instead. And that I don't want. Thank you guys!
    Best Regards,
    Rui
  • YamFazManYamFazMan Posts: 19,028
    Superusers
    edited January 29
    Hi
    @ruimau
    Have you tried a Soft restart on the device ??? Or several Soft restarts one after another ???

    RESETTING YOUR NAVIGATION DEVICE
    https://help.tomtom.com/hc/en-gb/articles/360013957499-Resetting-your-navigation-device
    Charge the device for at least 2Hrs….
    (Preferably using something like a Smartphone Charger using the Tomtom USB lead)...
    OR have the device plugged into the power supply while the device is restarting....

    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    _______________________
    _______________________

    Contacting Tomtom Support….
    Due to COVID-19 the phone service has been suspended
    For Tomtom Support Email or Chat lines...
    (Monday to Friday Normal Office Hours)

    The way of contacting Customer Services has changed

    (1)... A couple of Tips when Contacting Tomtom Support....
    Here... https://discussions.tomtom.com/en/discussion/comment/1714844/#Comment_1714844
    _________________________

    (2)... Tomtom FAQ … How to Contact Tomtom Support....
    Here… https://help.tomtom.com/hc/en-gb/articles/360015568919-How-to-contact-TomTom-support

    Stay Safe... ATB YFM
Sign In or Register to comment.

Who's Online in this Category0