Start 50 'not connected' — TomTom Community

Start 50 'not connected'

RichieMcCRichieMcC Posts: 2 [New Seeker]
Hi,

I have a Start 50 last updated in April 2020 and when I went to install the new updates the MyDrive Connect app says the device isn't connected.

I have used original leads and different USB ports and even tried a different laptop but still it does not detect the SatNav. Has anyone else had this problem and have you managed to resolve it.

Thanks

RichieMcC

Answers

  • VikramKVikramK Posts: 11,581 Moderator
    Hi @RichieMcC

    Welcome to the community! Have you tried the troubleshooting steps from the article here- https://help.tomtom.com/hc/en-gb/articles/360013900240

    If you are using Windows 10 then some more advice is available here-
    https://help.tomtom.com/hc/en-gb/articles/360013959799

    Regards, Vikram
  • RichieMcCRichieMcC Posts: 2 [New Seeker]
    Hi VikramK,

    Thank you for your post. I have tried everything suggested in those links but the device still won't connect to laptop. It does take a charge when plugged in, but the laptop or 'MyDrive Connect' doesn't connect to it.

    Regards,

    RichieMcC
  • bkunzwybkunzwy Posts: 3 [Apprentice Traveler]
    I have a somewhat similar problem as RichieMcC. I have a Go50 which WILL connect with my Mac that has USB A ports and allow me to connect directly. I have a new Mac, however which only has USB C ports on it. I have purchased a USB -c Hub for the new Mac (CZHoon Adapter). When I plug Go50 into this hub it is receiving a charge (I know this because the Go50 turns on) but MyConnect says the device is not connected. I contacted CZHoon and they indicate it is likely a driver for the Go50 needs to be updated. Can you help here?
Sign In or Register to comment.

Who's Online in this Category0