TomTom Go 5100 computer won’t restore device

DaveBenson68 Registered Users Posts: 7
Apprentice Traveler
So my 5100 tomtom is stuck in a cycle where it says ‘connect to computer‘ which I do with the original cable, open mydrive and computer says ‘restoring device‘ it does this up to 100% then restarts the tomtom and the MyDrive on the PC claims ‘no internet connection’ which of course is working fine. The process then starts all over again, it’s done it 30-40 times and not restored anything ! Help 🙏😳
I even tried another pc with new mydrive download to no avail, also the cable works fine on my brand new GO premium.


  • VikramK
    VikramK Administrators Posts: 13,718
    Hi @DaveBenson68

    I have asked my team to push some repair scripts for the installed firmware on the device.

    Just connect it to MyDrive Connect and let the jobs process. The device might reboot during the process.

    Once done check if it continues to restore in a loop.

    Regards, Vikram
  • DaveBenson68
    DaveBenson68 Registered Users Posts: 7
    Apprentice Traveler
    Hi, thanks for your prompt reply 👍
    I tried last night and again just now, still stuck in a loop restarting, mydrive opens, restores device to 100% but then on the ‘my devices page‘ where the updates show says ‘connecting’ but doesn’t, then restarts and it all happens again !
  • DaveBenson68
    DaveBenson68 Registered Users Posts: 7
    Apprentice Traveler
    Any ideas please ?
  • ARP
    ARP Registered Users Posts: 1
    New Seeker
    I have a problem just the same DaveBenson68. I returned to my old PC (Windows 10) to install new maps. I gave up trying on my desktop Mac because it froze the machine and caused all sorts of mayhem in trying to recover the files that I already had open on it. It has caused major problems on the Mac like that in the past but not as bad. So I dumped, or tried to dump, the My Connect software from the Mac and returned to the old PC. Trouble is, it takes hours at snail's pace to get to a halt when it says the internet is not working or it just stops downloading or verifying and I have to start again. If you can "push" any reliable software to it for me, both for the Mac and the PC, I would be very very very grateful.