MyDrive Connect for MAC is not working on BIG SUR — TomTom Community

MyDrive Connect for MAC is not working on BIG SUR

bodakabodaka Posts: 4 [Apprentice Traveler]
edited December 2020 in MyDrive Connect
Haven't used my device for a long time, downloaded newest MyDrive Connect for MAC, it recognized the device and updated NAV Core, rebooted device. After that unable to connect.
Found log file filled with many identical lines
2020-12-01 22:17:59.398|50331742|Error|SecureStorageMac::RemoveItem|Failed to remove password for cookie or proxy tomtom.com.key.3: error The specified item could not be found in the keychain.
Tried removing TomTom folder from Application Support and start over but the same result.
Device seems to work just fine, maps are present.

Comments

  • lampardlampard Posts: 5,254 Moderator
    Hi @bodaka

    Welcome to the Community! Few users managed to resolve the KeyChain Access problem with MyDrive Connect by following the steps here.

    Hope it helps!

    Regards, lampard
  • bodakabodaka Posts: 4 [Apprentice Traveler]
    edited December 2020
    @lampard Error says that item is not found. That is why a suggestion to delete it is useless.
    There is nothing in keychain that matches "tomtom" as shown here:
    le8v0s3x2mne.png
    Are there any other suggestions?
  • bodakabodaka Posts: 4 [Apprentice Traveler]
    @lampard based on https://help.tomtom.com/hc/en-gb/articles/360013900260 macOS 11.0.1 Big Sur is not supported, even macOS 10.15 Catalina is not supported.
  • lampardlampard Posts: 5,254 Moderator
    Hi there @bodaka

    We've not seen any reports of MyDrive connect not working on the new version of macOS (Big Sur) and I think the above FAQ you mentioned is outdated and I'll report it to the team. However, try a clean re-installation of the MyDrive Connect application and see if this helps.

    Regards, lampard
  • gking34gking34 Posts: 1 [New Seeker]
    I am in the same boat as @bodaka. I have 2 Macs, one running Big Sur and the other running Catalina. I have reinstalled MyDrive Connect on both computers, but neither of them is able to connect to my GO 600 using MyDrive Connect. Not sure what to do now.
  • bodakabodaka Posts: 4 [Apprentice Traveler]
    I moved my attempts to Catalina and after significant struggle, repeating workaround many times, e.g. deleting tomtom* keys from keychain and even tomtom data folder from user home was able to update map after several attempts. One of the requirements was to disable screen saver and computer sleep since MyDrive Connect could not cope with either one and complete restart including workaround above required. This is the most horrible piece of macOS software I have ever seen. Unfortunately I have no access to Windows desktop at this time.
  • BolampauBolampau Posts: 1 [New Traveler]
    Can't get this to work on Mac OS Big Sur either. Re-downloaded software, played with keychain and given up!
  • nomadsnomads Posts: 1 [Apprentice Seeker]
    i had a long chat with TomTom and then Apple with not solution but when I checked on the tomTom website the download list does not include Big Sur or the M1 chip. HELP
  • GPSUserNowGPSUserNow Posts: 5 [Apprentice Traveler]
    You must uninstall your old MyDrive Connect and clear related files before installing the new version 4.2.11.If you don't, you'll be unable to get past the "Allow TomTom to make changes" screen. Pasted below is info from this web site that allows TomTom to work with BigSur 11.2. After trashing the app, follow these instructions but look for "TomTom" not "MyDrive Connect" in your two Library files: one at the top level and the other inside your user file. Pasting starts here:

    MacOS
    Right-Click the MyDrive Connect in the Dock then choose Quit to close it. (If you’re using a track-pad, hold your finger until you get a pop-up.if you cannot see it on the menu, press the Alt/option on the keyboard [Latest Macs use ‘option’ again rather than ‘alt’])
    Uninstall MyDrive Connect> In the Finder menu, click Go and then Applications >Drag MyDrive Connect to the trash.
    Alternatively, select MyDrive Connect and then, in the Finder menu, click File and Move to Trash.
    Delete MyDrive Connect folder/files from the Library. Go to Finder. In the top Apple menu, click GO >Click on Library (if you cannot see it on the menu, press Alt/Option on the keyboard).
    Go to Application Support and delete the MyDrive Connect folder/file.
    Now go back to the Library, go to the Caches folder and delete the MyDrive Connect folder/file here as well. Empty the trash.
    Go to Installing MyDrive Connect> Select Mac OS X> Double click on the file MyDriveConnect.dmg in the Downloads folder> You will see a picture of a computer and an unpacked box. Double click the box.
    Follow the installation wizard.
  • Matt4321Matt4321 Posts: 8 [Apprentice Seeker]
    Tried the keychain trick, the remove-delete-files/folders-reinstall, updated MAC IOS to Big Sur, reset the DHCP - nada, nothing. My Rider 450 is still not connecting :( Thankfully I borrowed a PC and it connected with 2 seconds so at least I know that it's not my device, just my stupid Mac.
Sign In or Register to comment.

Who's Online in this Category0