Amigo looses GPS signal when connecting USB data cable to the car — TomTom Community

Amigo looses GPS signal when connecting USB data cable to the car

It concerns a android 10 device Sony Xpreia 5II, with Amigo is 7.3670 (7693). When the USB cable is plugged into the car, Amigi is losing the GPSsignal . With Bluetooth only and no USB cable it works fine (Amigo is connected to the GPS). Tried to change the permission to "all the time", but only have the option "only while using the app" or "refuse". Could you please help?
For your info, on my old device with Android 8 it worked perfectly. I've also tried it when connecting the device to a PC with a USB cable, and then it also looses the GPS signal. So it seems it is not possible to have a data connection running via USB.

Answers

  • VikramKVikramK Posts: 12,678 Moderator
    Hi @fdjsuurmond

    I doubt is the problem could be specific to the app. Sounds more like a phone issue.
    Have you observed this only while using the TomTom AmiGO? I would want you to test and see if any other apps(which use GPS) continue to get the signal when the phone is connected via the USB cable?

    Regards, Vikram
  • fdjsuurmondfdjsuurmond Posts: 2 [Apprentice Seeker]
    Hi @VikramK

    Thanks for you answer. Bases on this we performed differential tests with other apps on the device, which are using the gps. We have to confirm that it's only related to TT AmiGo. With the tests we did we run at the same time following apps
    • Route Planner from Land Rover Here
    • Waterkaartenapp or Biggerworks Nautical Maps
    • AanUit.net app

    All above mentioned apps work well, and keep our car position updated on the map continuously, which means GPS location works well. With and without USB connection to the car.

    We observed however that at the same time TT AmiGo updated the location of the car not continuously. It seems the location gets updated with a time-in-between of 20-60 sec. Also when only the TT AmiGo app is running, it's updated with this low frequency, so not working at all. As soon as we disconnect the device from the USB, TT AmiGo starts working correctly. It may be device related, but then only with AmiGo. So please check for a solution. We would prefer to keep using AmiGo in stead of changing to Flitzmeister.
Sign In or Register to comment.

Who's Online in this Category0