Unresponsive and slow Start 52 — TomTom Community

Unresponsive and slow Start 52

I have a Start 52 which is often slow or totally unresponsive. Lag is unbelievable.
Battery is always flat/showing as nearly flat, regardless of whether it has been plugged into car charging port or lap top for hours!
This is by far the worst sat nav I have ever had! Absolute waste of money if it doesn't want to work!

Comments

  • YamFazManYamFazMan Posts: 17,986
    Superusers
    Hi
    @Blackers
    Welcome to the site....
    Have you tried a Soft/Drum roll restart on the device ??? This restarts the devices Operating System afresh....
    See... https://discussions.tomtom.com/en/discussion/comment/1729353/#Comment_1729353
    Blackers wrote: »
    I have a Start 52 which is often slow or totally unresponsive. Lag is unbelievable
    Just a thought, ??? Check how much Free Memory there is for working space, 400MB is the bare Minimum for the device to operate correctly....
    Tap 4Dot (.... Menu) --> Settings --> System --> About... Free Space....
    Blackers wrote: »
    Battery is always flat/showing as nearly flat, regardless of whether it has been plugged into car charging port or laptop for hours!(Snip)
    The Previous NAV4 and Latest (NAV5 Wi-Fi) devices are quite power hungry and can go into "Power saving mode" if not supplied with enough power Are you using the Tomtom supplied cable and Tomtom supplied Power Adapter The Charger Adapter and USB Cable supplied by Tomtom WILL run and charge the device at the same…
    See... https://discussions.tomtom.com/en/discussion/comment/1709218/#Comment_1709218

    Stay Safe... ATB YFM
Sign In or Register to comment.

Who's Online in this Category1

grd5
grd5