Activities wont upload correctly and dont update "Map my Fitness" — TomTom Community

Activities wont upload correctly and dont update "Map my Fitness"

For a couple of months now (since 27 August 2020 actually) when I connect my Multisport GPS watch to my Windows computer it tells me it can't upload the files and to try again later. When I look at the settings it says (as at 02 November) I have 26 activities waiting to upload to Tom Tom Sports. When I press the "Try Again" button they still dont transmit. (I can see the files located in the appropriate folder of my computer)

Now the strange thing here is that I can manually log into Sports Connect and the activities are actually there BUT (and there's always a "but") they wont transfer to the Map My Fitness site. The Sports Connect site also says "an activity export has failed, please re-enter your login details or check again later". This message is directly related to the Map My Fitness export as it appears it doesn't want to log into the site (which it has done for the last year or so)

I have tried the following:
1. Logged into Sports connect before connecting the watch
2. Logged into Map my Fitness and ensured Sports Connect is connected to this site...before connecting the watch
3. Deleted the link to the Map My Fitness site
4. Deleteing and re-installing the Sports Connect App
5. Changing the default browser from Chrome to Edge to internet explorer to Opera

I am stuck. I know people have had this problem in the past but I have tried all those suggestions and nothing seems to work. Yes, I can manually transfer the files but then why do I have an app that is supposed to do it for me. I may as well just write it on a piece of paper and use a quill and ink:-)

Hopefully someone has some helpful suggestions.

Answers

  • tfarabaughtfarabaugh Posts: 16,676
    Superusers
    edited November 2020
    You can need to remove the TomTom link in MMF. It looks like it can only be done in the mobile app under Settings> Apps & Devices. Now go back into TomTom Sports and add MMF as a connected app. You should be prompted for your MMF login credentials which will reset up the link. This should reset all the upload settings and get your activities back to MMF. However, Under Armour just announced they sold MapMyFitness and are shutting down Endomondo, so the issue may be on their end.
  • AlanBasAlanBas Posts: 4 [New Seeker]
    Thanks for the prompt response. First off, I actually added this question to the wrong area as my watch is not a Spark or a runner 2 or 3...sorry.

    I have tried to "revoke access" in the MMF site. It only shows up on the PC based site and I can click on the Revoke access link but it does nothing. The "connected to" icon remains there. When I tried it on the mobile app on my tablet Tom Tom is not even listed as a connected app or even one that can be connected. From what you are saying about Endomondo being sold (I don't use this) from MMF and was it Tom Tom selling something we are probably losing some functionality in the long run...which is annoying
  • mrslkennedymrslkennedy Posts: 2 [New Seeker]
    I am exactly the same, have tried everything, revoking access from Mapmyrun and mapmyfitness and deleted all the apps and reinstalled everything but nothing seems to work.

    Noticed this stopped in August for me also, worked perfectly before then and nothing had changed.
  • mrslkennedymrslkennedy Posts: 2 [New Seeker]
    This is response I received from mapmyfitness:

    Thanks for writing in about this.

    Sorry to hear about any trouble connecting TomTom to MapMy. To connect your TomTom account to MapMy you will need to use their MySports software on your computer, or the TomTom MySports website to link your accounts. For now if you are having issues, please try following the troubleshooting tips outlined in this TomTom guide to connect to MapMy:

    TomTom MySports connect to MapMy Instructions

    If your issues persists, this could be a problem on their end. Syncing between TomTom and MapMy is maintained through the TomTom team by accessing our public API. You can contact their support team here. I'll also pass this along to our integrations team in case there is something on our end causing syncing conflicts.
Sign In or Register to comment.

Who's Online in this Category0