GO Navigation App calculates the route through road block — TomTom Community

GO Navigation App calculates the route through road block

rabero1985rabero1985 Posts: 19 [Legendary Explorer]
I had this morning a major bug in the app.
Tomtom go navigation 2.3.1 for Android on a Huawei Fig LX 1 with Android 9.1.

Tomtom calculate a route that is not possible because of a road block.
The live map in My Drive is correct.
I personally sended this road block in mapshare and it was approved, so this is A HUGE BUG in the app. This things should be in the WEEKLY updates at least.
Where is the time (i had tomtom 700 till go 6200) where it had daily updates !

Also sometimes if you search for something i get weird signs in the results.
See all my attachments please.

This discussion was created from comments split from: GO Navigation 2.3.


  • rabero1985rabero1985 Posts: 19 [Legendary Explorer]
    At this point, I seriously regret my purchase. Yesterday at Ikea Hasselt he wants to send me into a street only for permit holders. This has been like this for YEARS. Later in the center of Hasselt he wants to send me several times along the wrong side in one direction streets. Speeds are also not correct in many places the more I drive it. Unacceptable. The maps are absolutely not up to date!
    Ps: Waze got me out of trouble yesterday. Then rather an app with advertising that DOES know the way.
  • rabero1985rabero1985 Posts: 19 [Legendary Explorer]
    I simulated the route of yesterday and again in Mydrive it is correct !! WHAT THE HELL IS GOING ON???
    Put the maps or whatever it is of mydrive in the app pls, these are correct in routing !
    So i report it in mapshare but it seems it is already correct on mydrive, so the problem is really in the data of the app. I already did a full clean reinstall 2 times but no changes. It seems also that i don't recieve the weekly updates !
  • eddydceddydc Posts: 67 [Renowned Trailblazer]
    The weekly updates need to installed manually via the settings menu. It's incomprehensible why this can't be done automatically when eg one has chosen via a setting to do so.
    I guess we have another understanding than TT on what a functional and user friendly application should be.
  • rabero1985rabero1985 Posts: 19 [Legendary Explorer]
    Hi eddydc,
    Yes that's true what you say. I was aware that you must do it manually. But if I go in the settings to the map, it says up to date. Now I did a clean reinstall so maybe that's the case. So now I'm gonna wait and see if I get it this week.
    I hope to get an answer why there is so different and wrong routing in the app. I wonder if it is also in ios like this.
  • eddydceddydc Posts: 67 [Renowned Trailblazer]
    It should be availability every Monday evening, but last week, I wasn't able to update the maps either.
    One could say that there were no updates for Belgium, but I have also The Netherlands and the upper part from France installed.
  • tgoldtgold Posts: 2,163 [Revered Voyager]
    edited October 26
    Last week I received updates to only my USA maps but not my European ones. And the same so far today.
  • rabero1985rabero1985 Posts: 19 [Legendary Explorer]
    I have installed whole Europe on SD card.
  • eddydceddydc Posts: 67 [Renowned Trailblazer]
    This is the second consecutive week without updates. What is going on? When will this be fixed?
  • rabero1985rabero1985 Posts: 19 [Legendary Explorer]
    Here also nothing today till now. I put also reviews on the playstore but like here you get no reaction of staff member from tomtom. Very disappointing. I remember another support from tomtom in the past. If you don't care about your users anymore and your products, then stop with the whole thing and don't let people pay for it.
  • eddydceddydc Posts: 67 [Renowned Trailblazer]
    Check my other forum post
  • lampardlampard Posts: 4,991 Moderator
    Hi @rabero1985

    Thank you for reporting the map error! I've already raised an internal ticket about it and I'll post back here once there's an update.

    About the weird signs in the search results, we would appreciate if you can provide us with the below information:
    • Were you connected to the internet when it appeared in the results?
    • Is online search in settings enabled/disabled?
    • Device language under the phone settings
    • List of installed map regions
    • Precise location
    • If possible what search string caused this malformed text
    • Any other changes in Android, for instance, changes in developer options if any
    Regards, lampard
  • rabero1985rabero1985 Posts: 19 [Legendary Explorer]
    Hi @lampard,
    Thx for answering and investigating.
    To answer you questions:
    Wi-Fi or 4g connected,
    Online search enabled,
    Netherlands Belgium language,
    Whole Europe map installed,
    Krakelaarsveld 27, 2200 Herentals, Belgium,
    I typed 'Verwimp doe'
    No android changes.
  • lampardlampard Posts: 4,991 Moderator
    Thank you @rabero1985 ! I'll send this to my team.

    Regards, lampard
  • eddydceddydc Posts: 67 [Renowned Trailblazer]
    edited October 27
    rabero1985 wrote: »
    Online search enabled,

    Maybe a stupid question, but how does one enable / disable online search and in which db does the online search happen?
  • rabero1985rabero1985 Posts: 19 [Legendary Explorer]
    In the menu go to tomtom services and then you see online search on or off toggle.
  • eddydceddydc Posts: 67 [Renowned Trailblazer]
    Thx. It seems I have already switched it on but have forgotten I did so.
  • lampardlampard Posts: 4,991 Moderator
    Hi @rabero1985

    Thanks for providing the details for the weird signs appearing in the search results as we were able to reproduce it and now reported.

    On the other hand, the routing bug seems to be a bit complex and won't be solved with the weekly map update or recent app update unless it gets fixed internally. I'll keep you posted on the updates.

    Regards, lampard
  • rabero1985rabero1985 Posts: 19 [Legendary Explorer]
    Hi @lampard ,
    you're welcome. I'm glad that you could reproduce it.
    Also good to know that there is be a work in progress on the issues :-)
    Thx for keeping updated.

  • rabero1985rabero1985 Posts: 19 [Legendary Explorer]
    edited November 11
    In latest version 2.3.3 it seems that the weird signs are gone. Bug fixed at my side.
    Hopefully waiting for the fix of the road block issue.
    But good job so far.
  • rabero1985rabero1985 Posts: 19 [Legendary Explorer]
    I tried the same example of routing in the amigo app and there it's also correct. It avoid the road block.
    So the problem is in the offline maps or the app.
    I find it weird that the free app is better performing then the paid one.
Sign In or Register to comment.

Who's Online in this Category0