GO premium x saying Traffic and speed camera Expired

Terry-S1234
Terry-S1234 Registered Users Posts: 2
Novice Seeker
edited December 2021 in Devices using Wi-Fi®
Tom tom Go premium x, 3 months old, now saying Traffic and speed camera Expired, i have done a reset but makes no difference, also saying that GPRS is not active, any help would be greatly appreciated

Best Answer

Answers

  • Lochfrass
    Lochfrass Posts: 17,766
    Superuser
    edited October 2020
    Please contact the Support. They can sort it out.
    https://discussions.tomtom.com/en/discussion/comment/1714844/#Comment_1714844

    Note: When your device is in WIFI range, then the GPRS status is shown as "disconnect"
    Wifi has more priority than GPRS
  • DougLap
    DougLap Posts: 9,853
    Superuser
    Hi @Terry-S1234

    Before you try Customer Support it would appear that the settings for your unit need changing on the TT servers.

    Hopefully @VikramK or @lampard will pick this up on Monday and make the changes for you. Look back here on Monday when they should be back on the Forum and let you know what they have done..

    Doug
  • Terry-S1234
    Terry-S1234 Registered Users Posts: 2
    Novice Seeker
    edited October 2020
    Hi Vikram thanks for your assistance, all working now
  • Geoff_Anderson1945
    Geoff_Anderson1945 Registered Users Posts: 12
    Master Explorer
    Go Premium X. Despite speed cameras and traffic showing as activated in the settings, the traffic alerts do not appear to be working at all. The double car symbol top right on the screen has an X through it. How do I resolve this please?
  • VikramK
    VikramK Administrators Posts: 13,795
    Moderator
    Hi @Geoff_Anderson1945
    Could you try the troubleshooting steps in the video below-



    Regards, Vikram