No voice on my GO 620 — TomTom Community

No voice on my GO 620

My 620 will not tell me how far the turning is away or when to to turn. The early warning is turned on but not working. Anyone got a fix.? I have done a reset but this has not fixed it.

Answers

  • YamFazManYamFazMan Posts: 17,991
    Superusers
    edited October 23
    Hi
    @Edfigg
    Welcome to the site....
    Tap 4Dot (.... Menu) -->
    Are any of the Sound Icons slashed through ???

    dy49cl5hc6cc.jpg
    Are you using a TTS (Text to speech) Computer Voice ??? They have a far greater vocabulary than the recorded voices....

    Stay Safe... ATB YFM
  • EdfiggEdfigg Posts: 5 [Novice Seeker]
    edited October 23
    There are no slashes just the Day/Night and I am using Karen for the voice. It only tells me what time I will arrive at the destination. I have another TomTom which works fine. I compared that with the 620 and both setting are the same.
  • YamFazManYamFazMan Posts: 17,991
    Superusers
    Hi
    @Edfigg
    Have you tried a Soft/Drum roll restart on the device ??? This restarts the devices Operating System afresh

    RESETTING YOUR NAVIGATION DEVICE
    https://help.tomtom.com/hc/en-gb/articles/360013957499-Resetting-your-navigation-device
    Charge the device for at least 2Hrs….
    (Preferably using something like a Smartphone Charger using the Tomtom USB lead)
    OR have the device plugged into a power supply while the device is restarting
    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    I use a Soft/drum-roll start after any upgrade large or small.
    It’s also useful to keep in mind for sorting out most minor niggles....

    Stay Safe... ATB YFM
  • EdfiggEdfigg Posts: 5 [Novice Seeker]
    I think I may have solved it. By changing the voice to a male I get different options so it looks like I may have fixed it. I'll try it out later today. Thanks for your help. I'll post back.
  • EdfiggEdfigg Posts: 5 [Novice Seeker]
    Just getting back to you. It's now all working fine. Many thanks for your help. :)
  • YamFazManYamFazMan Posts: 17,991
    Superusers
    edited October 25
    Hi
    @Edfigg
    You're welcome, glad you're sorted :)

    Just an afterthought....
    When you were using the Karen English (Australian) TTS Computer voice....
    Check... Tap 4Dot (.... Menu) --> Setting --> Language & Units --> Language... Were you also using the matching English (Australian) Language ???

    Stay Safe... ATB YFM
  • EdfiggEdfigg Posts: 5 [Novice Seeker]
    In answer to your question, Were you also using the matching English (Australian) Language ???..Yes I was.
Sign In or Register to comment.

Who's Online in this Category0