AmiGO not working in overlay / background (Samsung devices) — TomTom Community

AmiGO not working in overlay / background (Samsung devices)

JürgenJürgen Posts: 6,630
Community Manager
For some users, AmiGO does not work when put in overlay (widget) mode, or in the background. The following are some of the signs that your app has stopped working:
  • Your current speed and speed limit stop updating. The Overlay widget looks “frozen”.
  • You stop getting warnings and instructions, both visually and through voice (TTS).

Samsung Galaxy S8/ S9 / S10 / S20

Ensure that your device is not putting AmiGO to sleep.
  1. Start Device care from your phone's settings.
    49gagaumjep4.png
  2. Tap on the Battery icon.
    5wkh7tggru7r.png
  3. Tap on Menu (3 dots in the top right) > Settings.
    sflgegfk3b24.png
  4. Only enable Notifications, disable the rest.
    5rcoefa2oj74.png
  5. Tap Sleeping Apps.
    ryt3akfhqol1.png
  6. Wake up all apps using the Trash icon.
    33gba94xbm63.png

All Samsung Devices (including S8, S9, S10, S20)

Turn off App Power Monitor by following these steps:
  1. Open Settings > Device maintenance > Battery.
  2. Tap on Menu (3 dots in the top right).
  3. Disable App Power Monitor. In some devices, this is also called App Energy Monitor.

OR

On older devices, the path may be as belows:
Phone settings > Applications > Menu (3 dots in top right corner) > Special Access > Optimize Battery Usage > Find AmiGO on the list and make sure that it is not selected.

Comments

  • Bert1947Bert1947 Posts: 2 [Apprentice Seeker]
    edited July 30
    Already disabled on my Samsung Galaxy S21! So it's not about that



    Mod edit: Machine translated (Dutch)


Sign In or Register to comment.

Who's Online in this Category0