6200 TRAFFIC NOT WORKING — TomTom Community

6200 TRAFFIC NOT WORKING

I have recently purchased Live Traffic. Orders completed and paid. The traffic on the device says it expired 23/04/2020. I have tried resetting the device, connecting to WiFi and USB (My drive on PC). Can switch old maps and download new. It seems the subscription are not activated. I think I have now removed the device from my account on the website by error and can't put it back on... Please can you help.

Answers

  • YamFazManYamFazMan Posts: 17,993
    Superusers
    Hi
    @algisleo
    Welcome to the site....
    The restrictions as a result of the Coronavirus, Social Distancing and people working from home, are probably delaying the Activation of Accounts and the Allocation of Maps & Services to Account’/Devices....
    @VikramK or @lampard the Forum Moderators should pick this up, It's probably a little late for Today... More likely to be Tomorrow to check/correct your Tomtom Account status.....

    Stay Safe... ATB YFM
  • VikramKVikramK Posts: 10,571 Moderator
    Hi @algisleo

    Welcome to the community! I have reviewed your TomTom account and I don't see the TomTom GO 6200 linked. Perhaps it is set up under a different account.

    Could you send me the serial number of your device through a private message, please?

    Thanks, Vikram
  • AgnieahkaAgnieahka Posts: 1 [New Seeker]
    I've got the same issue cant seem to get the live traffic 3ven though I've purchased a subscription?
  • YamFazManYamFazMan Posts: 17,993
    Superusers
    Hi
    @Agnieahka
    Welcome to the site....
    The restrictions as a result of the Coronavirus, Social Distancing and people working from home, are probably delaying the Activation of Accounts and the Allocation of Maps & Services to Account’/Devices....
    @VikramK or @lampard the Forum Moderators should pick this up Tomorrow to check/correct your Tomtom Account status.....

    Stay Safe... ATB YFM
  • lampardlampard Posts: 4,994 Moderator
    Hi @Agnieahka

    Welcome to the Community! I don't see any device linked to your account, Can you send me the serial number of your device through a private message, please?

    Regards, lampard
  • stephen_allisonstephen_allison Posts: 2 [Novice Seeker]
    edited October 22
    I am currently experiencing the same problem with my 6200. After purchasing the subscription, it is failing to appear on my device. I have done a reset and driven a number of times to pick up gps, but live traffic is not appearing. I purchased my subscription on the 8th of September 2020.
  • DougLapDougLap Posts: 6,593
    Superuser
    Hi @stephen_allison

    Why have you purchased a Traffic subscription for a device that comes with lifetime Traffic?

    The failure to appear will not be because you need to pay for the service. you should contact Customer Support and seek a refund and assistance with restoring the Traffic to your device wi=hich may be a setting change on the Tomtom Servers.

    Tap Support at the top of this page
    Sign in Top Right
    Tap Contact us
    Type help and hit return
    Tap Contact us
    Select Contact an expert
    Select Chat
    Chat is very busy so may take a few attempts to get a connection

    There is no Phone line service whilst so many are working from home.

    Doug
  • stephen_allisonstephen_allison Posts: 2 [Novice Seeker]
    Hi DougLap, it explicitly states on my device in the ‘about’ tab under menu >Settings > system, that traffic and speed camera updates are expired. I follow your instructions and see what happens.
  • DougLapDougLap Posts: 6,593
    Superuser
    edited October 22
    Hi @stephen_allison

    That suggests that your units settings need changing on the TT servers and hopefully @lampard or @VikramK will pick this up and make any appropriate changes. Look back here tomorrow.

    Lifetime Maps , Traffic and Cameras will only stop when Tomtom announce it. They are still honouring Lifetime Map updates on old devices that they have declared obsolete.

    Doug
  • lampardlampard Posts: 4,994 Moderator
    Hi @stephen_allison

    Welcome to the Community! The device linked to your account is the GO Professional 6200 trucker device which only has 1 year of Traffic subscription on it. I see that you already contacted support to get a refund on your recent order.

    Best, lampard
  • DougLapDougLap Posts: 6,593
    Superuser
    Hi @stephen_allison

    I see from @lampard ’s post that your unit is a Truck unit That being the case my answer to your original post would have been as has been stated that the Traffic is a subscription based service after 1 year.

    I suggest that you amend your Profile to reflect the unit is a Go 6200 Professional. You may need to open your Profile in a Private window to make the amendment.

    Doug
  • AmericosilAmericosil Posts: 3 [Apprentice Traveler]
    Hi Vikram, i have a GO5000, S/N QRxxxxKxxxxx with lifetime map updates Traffic and speed cameras, I bought it in South Africa and now have moved to Europe. Since then my live traffic doesn't work. although my live services says active.

    Americo

  • VikramKVikramK Posts: 10,571 Moderator
    edited October 29
    Hi @Americosil

    The GO 5000 model comes with factory embedded Traffic Services that are region-specific. That is the reason the device won't connect when you travel to a different country that not in the Traffic coverage section associated with the device.

    Regards, Vikram
  • DougLapDougLap Posts: 6,593
    Superuser
    edited October 30
    Hi @Americosil

    Traffic and Camera data is tied to the region within which the devices are purchased so a GO 5000 bought in Europe would only work here. It is saying the data is active as it still is for SA.

    Try contacting Customer Support and explaining you are now living in Europe and see if they will change your units settings on their servers to activate the Traffic and Cameras for Europe now.

    Doug
Sign In or Register to comment.

Who's Online in this Category1

delboy99
delboy99