i cant add my device to my new account — TomTom Community

i cant add my device to my new account

i cant add my old device to my new account

Best Answers

  • andyyoung71_andyyoung71_ Posts: 3 [Novice Seeker]
    Accepted Answer
    DougLap wrote: »
    Hi @andyyoung71_

    You need to delete any reference to the old account details from the old device via a Factory reset then add the new account info.

    Doug

    Thanks for you advice but sadly this still did not fix the problem. My drive connect still knows my device is registered to my old e mail address. It ask if I want to register it to the email address I'm logged in with but when I click on add it still says, We are sorry something has gone wrong. It is currently not possible to add your device to your account. Please try again!

    I try and try but still nothing.

    I'm losing the will to live lol

Answers

  • rider1riderrider1rider Posts: 207 [Exalted Navigator]
    sure
    just login to mydrive connect with your new account and connect the device. it should ask if you want to link it to the new account.
  • DougLapDougLap Posts: 6,338
    Superuser
    Hi @andyyoung71_

    You need to delete any reference to the old account details from the old device via a Factory reset then add the new account info.

    Doug
  • andyyoung71_andyyoung71_ Posts: 3 [Novice Seeker]
    Accepted Answer
    DougLap wrote: »
    Hi @andyyoung71_

    You need to delete any reference to the old account details from the old device via a Factory reset then add the new account info.

    Doug

    Thanks for you advice but sadly this still did not fix the problem. My drive connect still knows my device is registered to my old e mail address. It ask if I want to register it to the email address I'm logged in with but when I click on add it still says, We are sorry something has gone wrong. It is currently not possible to add your device to your account. Please try again!

    I try and try but still nothing.

    I'm losing the will to live lol
  • andyyoung71_andyyoung71_ Posts: 3 [Novice Seeker]
    Hi

    I also tried that but it never worked but for some strange reason late last night I had an email from tomtom saying my device is now linked to my account. I again tried it and indeed it worked! I wonder if there was an issue their end.

    I would like to thank you for the help you have given me in trying to fix my problem.

    Regards

    Andy
  • DougLapDougLap Posts: 6,338
    Superuser
    Hi @andyyoung71_

    Glad you are sorted.

    Doug
Sign In or Register to comment.

Who's Online in this Category0