Bluetooth connection with iPhone 5 — TomTom Community

Bluetooth connection with iPhone 5

mpatzmpatz Posts: 9 [Apprentice Seeker]
I have changed my sim card recently. Is it possible that this is the reason for my connection problem with my iphone 5 via bluetooth?

Best Answer

Answers

  • LochfrassLochfrass Posts: 14,760
    Superusers
    When you have iOS 13 then are Bluetooth problems known at TomTom.
  • mpatzmpatz Posts: 9 [Apprentice Seeker]
    Yes I have IOS 13, but what to do?
  • mpatzmpatz Posts: 9 [Apprentice Seeker]
    Thanks for your answer. I will try what you suggest and maybe it is easier for me to switch to the german forum.
  • LochfrassLochfrass Posts: 14,760
    Superusers
    mpatz wrote: »
    ....and maybe it is easier for me to switch to the german forum.
    Maybe we write there together. I´m from Germany too and i only sometimes postin the english Forum part.
    Mostly in the German Forum. Fingercrossing that it works.
  • mpatzmpatz Posts: 9 [Apprentice Seeker]
    Thanks, it seems to work with the WIFI Hotspot, you suggested.
  • mpatzmpatz Posts: 9 [Apprentice Seeker]
    The WIFI connection via my iphone seems to be ok, but the connection to mydrive and traffic only works sometimes. Mostly I get the message "Dienst nicht verfügbar". When I switch to the WIFI connection of my home it gets connected to my drive and traffic. It is very frustrating. Maybe someone has another hint for me.
  • DougLapDougLap Posts: 7,769
    Superuser
    Hi @mpatz

    When Apple issued IOS13 it included a security change which has made the use of the My Drive App as part of the Bluetooth Connection process impossible. Now when you are Pairing your Phone to the TT unit you do not involve the My Drive App in the Setting up of the Bluetooth connection.

    Before you do the following delete/forget the Bluetooth pairings on the Phone and TT unit then turn both units Off and On.

    There is a difference in that now you include in the pairing process the Personal Hotspot on your iPhone .

    Go to settings on the iPhone and Turn the Personal Hotspot ON. .(Do not connect it to the TT units Wifi)

    Go to Settings /Bluetooth and turn the Bluetooth ON

    Turn the TT unit on and go to Settings/Bluetooth and select Add a Phone

    Tao the TT units name when it appears in Settings/Bluetooth and then Accept the Pairing numbers on both units.

    The TT unit should now have the Handsfree connect and the Traffic the latter provided that Data is enabled on your Phone

    You should note that when you are using the TT unit you need both Bluetooth and Personal Hotspot turned On but you will never be asked for the Personal Hotspots Password neither will it appear as linked if you open the Settings/Wifi on the TT unit.

    Regarding the My Drive App on the Phone that can still be used for creating routes etc as you would do on a PC but has no involvement in the Bluetooth process.

    Doug
  • mpatzmpatz Posts: 9 [Apprentice Seeker]
    Thanks for your answer I will try and report later.
  • mpatzmpatz Posts: 9 [Apprentice Seeker]
    I just tried what you suggested, but without success. The Bluetooth connection and the WIFI connection to the Phone is ok, but the connection to mydrive and traffic not.
  • DougLapDougLap Posts: 7,769
    Superuser
    edited September 2020
    Hi @mpatz

    What IOS have you on the iPhone

    I did say in my post, based on you having iOS 13 or later on your iPhone, that you do not connect the iPhones Personal Hotspot to the TT units Wifi facility. You pair the TT unit to the iPhone for Bluetooth but whiles you are Pairing it and then whilst the Unit is being used you need to have the Personal Hotspot on you iPhone set to On.

    You also do not involve the MyDrive App in the Bluetooth Pairing process or have it Open when the iPhone is connected by Bluetooth to your TT unit.

    Doug
  • mpatzmpatz Posts: 9 [Apprentice Seeker]
    Hi DougLap,
    I followed you description and it did work, but it seems to be not stable. I switched the personell hotspot off and then on again and it worked. I did the same a second time and it did not work. The Bluetooth connection seems to be ok, but Mydrive and Traffic is then not connected. I shut down TT and switched it on again, but without success.
    I think I have to live without this Traffic option.
    Thanks for your help
  • kieronkieron Posts: 458
    Superusers
    Hi there mpatz -

    You stated in your posting above on the 8th of September that you are currently using IOS 13 - therefore -

    Here is an excerpt posted by JURES (another forum contributor) as a temporary fix for iPhones using iOS 13+ operating systems end of January -

    If you pair the gps with your iPhone without MyDrive app, traffic works flawlessly - perfectly!
    You can even install the MyDrive app afterwards and use it for routing - but -
    JUST DONT PAIR your gps with the MyDrive app!!!
    Traffic will still work, MyDrive routing will work, the only thing that does not work will be smartphone features (calls/sms) but thats not important if using a motorbike.

    Traffic and MyDrive under iOS 13+ works!!!!!
    1. - Delete the MyDrive app on your iPhone
    2. - Delete old Bluetooth pairings of the gps on your iPhone
    3. - Connect the gps to your iPhone over Bluetooth under standard way
    4. - Install the MyDrive app
    5. - DO NOT pair your gps over the MyDrive app
    6. - Have personal hotspot on iPhone turned ON just for *Bluetooth and USB Only*
    - DO NOT pair gps with WiFi of this personal hotspot

    TRAFFIC AND MYDRIVE WILL WORK NON STOP!!

    Problem is in the MyDrive app (pairing through the app)

    ~Kieron adds~

    Additionally, also using the *Bluetooth and USB Only* pairing hotspot in your iPhone settings will be required for a stable connection and has less of a drain on your phone’s battery compared to the WiFi hotspot setting.
    I am currently using my Rider 500, Sena 5s and iPhone 7 Plus this way successfully.

    As JURES (the original contributor of this temporary fix) had explained, you can re-install the MyDrive app onto your phone, sign in to it and use it for routing to send to your devices, but just don’t pair the Bluetooth within the app to your gps.

    Good luck.
  • mpatzmpatz Posts: 9 [Apprentice Seeker]
    Thanks for your answer,
    I am using ios 13.2.2
    I deletet the mydrive app and wanted to set the option "personal hotspot on iPhone turned ON just for *Bluetooth and USB Only*". I could not find this option in the settings. WIFI is allways included.
  • CJOCJO Posts: 34 [Prominent Wayfarer]
    As iOS 14 is now out, has anyone actually tested this post the upgrade ?
  • kieronkieron Posts: 458
    Superusers
    Hi there mpatz -

    First of all, please go to settings on your iPhone and turn off Wi-FI. Make sure Bluetooth is on in Settings. Now go to the Personal Hotspot setting and where it shows
    “Allow Others to Join”, press the slider button and it should activate a pop up display that states “Wi-Fi is Off”. Below this should show
    “Turn on Wi-Fi” and “Bluetooth and USB Only”.
    Do not turn on Wi-Fi, only activate “Bluetooth and USB Only”
    The pop up display does not activate if you had Wi-Fi in operation.

    I now have iOS 14.0 currently on my phone, but as I believe the MyDrive app would need to be updated to work with Apple’s security permissions, I will leave things as per JURES’S recommendations as this works for me.
    :)
Sign In or Register to comment.

Who's Online in this Category0