Is my 520 now Obsolete? — TomTom Community

Is my 520 now Obsolete?

Lime2Lime2 Posts: 11 [Master Explorer]
Attempted to update Tomtom HOME on my Mac running Mac OS High Sierra 10.13.6.

Message: This package will run a program to determine if the software can be installed.

Then receive message FAILURE Installation cannot proceed, as not all requirements were met.

Having searched endlessly fro a fix of some description I decided to reset my 520 Device and also deleted My existing HOME app on the Mac.

Is the device now scrap?

Answers

  • DougLapDougLap Posts: 6,888
    Superuser
    Hi @Lime2

    Does your units serial number start with M2 or M4 as if so then they were declared obsolete and are no longer supported by Tomtom.

    Doug
Sign In or Register to comment.

Who's Online in this Category0