traffic and radar services seems not active since last update (Europe 1050.10249)

hzy870
hzy870 Registered Users Posts: 1
New Seeker
yesterday I did an update on the maps (two updates suggested and accepted) but since then no service seems active. In about screen both appears "active" but no speed-cams nor traffic appear on the device.

Answers

  • LAURE123
    LAURE123 Posts: 1,632
    Superuser
    Hi @hzy870

    First you can try to do a Soft Reset, i'ts like a "Resart" on a PC, it often solves small worries and you will not lose anything.
    ==> Device switch on and not connected to your PC: press and hold the On/Off button until you hear the drum sounds. This can take 30 seconds or more. The device restarts. If you see a black screen with white text, hold down the button until you hear the drum sounds.

    Check if MyDrive is enabled in your device:
    ==> Main Menu (4Dots ...) / TomTom Service (your email and password) activated
    Sometimes my device lose its password.

    If no improvement try the procedures of this FAQ and video:
    https://help.tomtom.com/hc/en-gb/articles/360014530220-TomTom-Traffic-or-LIVE-Services-isn-t-working

    If nothing work, contact TomTom Customer Service directly for further assistance. Only email or Chat during office hours, the phone service is stopped.
    https://help.tomtom.com/hc/en-gb/articles/360015568919-How-to-contact-TomTom-support

    If you have a problem with a page that returns to the home page, do " previous page" in your Web browser and use the "Esc" key on your keyboard to keep the page wanted.

    Regards.