TomTom app doesn't show suburb names, just shows Melbourne for every address

Krzystoffer
Krzystoffer Registered Users Posts: 3
Apprentice Seeker
The destination address search on the TomTom AmiGO app doesn't show suburb names, it just shows 'Melbourne' for every address. Does anyone have a fix for this ?

Answers

  • xwintech
    xwintech Registered Users Posts: 304
    Supreme Pioneer
    While this could be a software bug, make sure that you set to show suburb names in settings (if available).
  • DougLap
    DougLap Posts: 9,830
    Superuser
    Hi @Krzystoffer

    This issue has arisen recently on other TT applications and is being investigated. Hopefully will be resolved soon.

    Doug
  • Krzystoffer
    Krzystoffer Registered Users Posts: 3
    Apprentice Seeker
    No -- Appearance / Settings don't have any options to show suburb names;

    In the search field and history, this is what I get, No. Street Name, Melbourne, State, Postcode -- refer to image:

    11rsgnl1zc4v.jpg

    'Melbourne' is the metropolitan area of, not the suburb of Melbourne (3000), I imagine the same glitch in greater Sydney would just show 'Sydney' for every address.
    The Postcode is the only meaningful identifier, and unless users remember every suburbs' postcode they may have to refer to Google Maps or another navigation app to check the address.
    Alternatively, users will find themselves frequently being misdirected to a different suburb than that which they are destined -- that has been my experience many times with the AmiGO app.
  • mbuzz
    mbuzz Registered Users Posts: 1
    New Seeker
    This is so annoying. I have the same issue that all suburbs in the Sydney Metropolitan area show up as being Sydney. There are lots of streets with the same name and not everyone knows the postcode of the suburb they want. This should be a really easy fix. Come on TomTom.