620 Go Professional Connection Issue with iPhone — TomTom Community

620 Go Professional Connection Issue with iPhone

Andy1979Andy1979 Posts: 3 [Apprentice Seeker]
Hello.
I’ve just bought a new 620 Go Professional but when I try and connect my phone which is a iPhone 11 Pro Max running the latest iOS software all I’m getting is connected disconnected connected disconnected constantly. The satnav is all up to date to.

Any ideas?

Answers

  • kieronkieron Posts: 462
    Superusers
    Hi there Andy1979 -

    Here is an excerpt posted by JURES (another forum contributor) as a temporary fix for iPhones using iOS 13+ operating systems end of January -

    If you pair gps with iPhone without MyDrive app, traffic works flawlessly - perfectly!
    You can even install the MyDrive app afterwards and use it for routing - but - JUST DONT PAIR gps over the app!!!
    Traffic will still work, MyDrive routing will work, the only thing that does not work will be smartphone features (calls / sms) but thats not important on bike.

    Traffic and MyDrive under iOS 13+ works!!!!!
    - Delete MyDrive app on iPhone
    - Delete old Bluetooth pairings of gps on iPhone
    - Connect gps to iPhone over Bluetooth under standard way
    - Install MyDrive app
    - DO NOT pair gps over the app
    - have personal hotspot on iPhone turned ON just for Bluetooth and USB Only
    - DO NOT pair gps with WiFi of this personal hotspot

    TRAFFIC AND MYDRIVE WILL WORK NON STOP!!

    Problem is in the app (pairing through the app)

    Using the Bluetooth and USB Only pairing hotspot will have less of a drain on your phone’s battery compared to the WiFi hotspot connection.

    As JURES (the original contributor of this temporary fix) had explained, you can re-install the MyDrive app onto your phone, sign in to it and use it for routing to send to your devices, but just don’t pair the Bluetooth within the app to your gps.
  • Andy1979Andy1979 Posts: 3 [Apprentice Seeker]
    That’s great I’ll try that. Thank you.
  • Andy1979Andy1979 Posts: 3 [Apprentice Seeker]
    Hello. I’ve given this a few months and deleting the app hasn’t done anything to help but having personal hotspot on has helped a little. The satnav still disconnects every 15-20 seconds but live traffic is useable with it doing this.

    Only thing I’ve found is when I’m using my Bluetooth earpiece as well the tomtom causes issues with it.

    I’m now running iOS 14 on my iPhone with no improvement.

    Cheers.
Sign In or Register to comment.

Who's Online in this Category0