Updated failed Tomtom GO 500 — TomTom Community

Updated failed Tomtom GO 500

I'm trying to help a friend of mine update the maps on his Tomtom GO 500, but the update keeps failing when I try to install them on his SD card and there's not enough space on the device itself for some reason.
At first I tried with the larger European map (9 GB), but the last couple of times I've tried with the smaller one at just under 7 GB. Any ideas on how to get this working? I have a Tomtom GO 500 myself without SD card and I've never had a problem.

Answers

  • Lars-Olof ThidLars-Olof Thid Posts: 13 [Master Explorer]
    edited July 29
    I did a factory reset of the device, which brought it back to life, but trying to install the 9 GB map on the SD card fails and at the same time the map is removed from the device, so I have to do another factory reset...
    Why can you put an SD card in the device if you can't use it to store maps???
  • DougLapDougLap Posts: 5,532
    Superuser
    HI @Lars-Olof Thid

    The GO500 takes extra memory cards. They should be a Micro SD Class 10 memory card and usually you are best suited to take a 16gb or a Maximum 32gb card.

    If you have been using it for other purposes then put it in your PC and format it to Fat32. It should a full format not a quick format. Once that has been done then put it in the GO500 and then turn the unit on. If it does not ask you whether you want the card formatted for Maps then go:-

    Tap menu
    Tap Settings
    Tap System
    Tap Format Card.

    The GO500 will then do the necessary Tomtom format so it is ready for use I the unit.

    If you are getting a new card then I recommend a Sandisk, Samsung or similar Major manufacturer as some of the lesser known makes have been known to have issues..

    Doug
  • Lars-Olof ThidLars-Olof Thid Posts: 13 [Master Explorer]
    edited July 29
    Thanks for your reply @DougLap.

    The SD card has been used with my friends GPS previously, but whenever I try to install a map on the SD card the update fails and the map on the device is deleted so I have to do a factory reset in order to be able to get it up and running again. According to the MyDrive Connect software there is 14137 MB of free space on the SD card, but when I try to install the European map with buildings in Scandinavia (6880 MB) on the memory card it fails.

    I tried formatting the SD card from the Tomtom Go 500, but it says I can't format it as it's already formatted to Tomtoms filesystem and it's ready for use for maps and other Tomtom content.

    I did yet another attempt at getting this to work, but once again I get the infamous "Update failed. Please try again. If the update fails again contact support at www.tomtom.com/support."
  • DougLapDougLap Posts: 5,532
    Superuser
    edited July 29
    Hi @Lars-Olof Thid

    If you take the SD card out of the unit cn you start the unit normally as there is a valid map on it.

    If you can then I would do a full format of the card to Fat32 on a PC, not a quick format, and then insert it back into the unit and try again after it has formatted it.

    Just out of curiuosity is the card a major manufacturers card as some of the lesser known makes have had the odd issue.

    In the following Link you will see mention of a Software programme for SD card formatting. That might be worth a try.

    https://discussions.tomtom.com/en/discussion/comment/1711742/#Comment_1711742

    Doug
  • Lars-Olof ThidLars-Olof Thid Posts: 13 [Master Explorer]
    edited July 30
    Hi @DougLap.

    Yes, the unit will work normally without the memory card installed as I now have a map installed on the internal storage space.

    The memory card is a Samsung Evo 16 GB memory card that I think me friend purchased together with the unit.

    Unfortunately I don't have access to a card reader, neither in my PC at home nor at work as I work in the printing industry, which is MacIntosh based, and my friend doesn't have a computer either. He's retired and when he stopped working the company asked to have their computer back, which is why he asked me for help.

    I'll try to get a cheap one after work tomorrow as I'm going out for a round of golf in the afternoon today and see if that helps.

    Thanks for your help though, it's much appreciated!
  • Lars-Olof ThidLars-Olof Thid Posts: 13 [Master Explorer]
    Today I purchased a memory card reader and I put the memory card into it and plugged it into my PC. When I open up the memory card I see a bunch of files TOMTOM and TOMTOM.000-TOMTOM.007. If I go to properties it says the card has 0 bytes free. However, I am unable to format the memory card and even if I delete the files and close the window they appear again once I open the window again.

    Any ideas on what to do next?
  • YamFazManYamFazMan Posts: 17,059
    Superusers
    edited August 4
    Hi
    @""Lars-Olof Thid"
    Welcome to the site....
    The Memory Card Needs to be a Class 10 Micro SDHC Card 16 GB or 32 GB (Max Size)
    I always use the... SD Card Association Formatting Program for PC & Mac
    Here... https://www.sdcard.org/downloads/formatter/index.html
    Then the Card is formatted in the device with a Tomtom proprietary format

    For example, I cleared the MyDrive Connect Cache... Deleted & Reinstalled the USA Map without a problem

    Image of the MDC Cache folder....
    a4rcg1akhw63.jpg
    89 more files go here ... Total 94 files...

    vvh9y334a3ig.jpg
    You are seeing the proprietary Tomtom format of the Micro SDHC Card and the proprietary Tomtom filing system....

    See High capacity microSD cards SDHC....
    Here... https://www.androidauthority.com/high-capacity-microsd-cards-android-gary-explains-690710/

    Which Map were you trying to install... Was it the Full Europe Map ???
    The early Maps fitted easily onto 8 GB on-board Memory, but the Map sizes increases with every update... Now the 8 GB limit on-board Memory size on the NAV4 devices is an unfortunate, but real Catch22 situation....
    The latest NAV4 Full Europe Map size is now 9 GB +

    Important See Catch22... https://discussions.tomtom.com/en/discussion/comment/1686043/#Comment_1686043

    Stay Safe... ATB YFM
  • DougLapDougLap Posts: 5,532
    Superuser
    edited August 4
    Hi @Lars-Olof Thid

    When you insert a new card into a Tomtom unit it asks you if you want it formatted for Maps. When you say yes it then does a Tomtom specific format which create the files you are seeing but with nothing in them. When a map is then loaded onto the memory card it is done so using the pre -prepared Tomtom files that were created.

    If you disturbed those files then you will need, and should be able to, do a Full Format of the card on your PC too Fat32. A quick format will not work. Then when you re-insert it into the Tomtom unit you will have to get the unit to Format it again.

    Doug
  • Lars-Olof ThidLars-Olof Thid Posts: 13 [Master Explorer]
    edited August 4
    Hi @YamFazMan & @DougLap.

    The memory card is a Sumsung Evo 16 GB card which is a class 10 as far as I can see on Samsung's website, so that shouldn't be the problem. Also when I received the device from my friend he had maps installed on the card and the device was working although the maps were slightly outdated.

    I used the SD Card Association Formatting Program for PC and managed to format the memory card, however the device said that the card is already formatted to TomTom's file system, so I can't format the card in the device. Perhaps that's where the issue lies as I am still unable to install the 9GB map on the 16 GB memory card...

    OK, so I uninstalled the memory card and then did a factory reset of the device. I then unplugged the device from my computer and put the memory card in the card reader and used SD Card Association Formatting Program for PC to format the memory card. I then switched the device off, installed the memory card and started the device. When I try to format the memory card I get the same message that the memory card already has TomTom's filesystem, so I can't format it. Now when I start MyDrive Connect it fails to recognize the memory card.

    After restating MyDrive Connect I can now see the memory card, but trying to install a map onto the card will fail for some reason...
  • DougLapDougLap Posts: 5,532
    Superuser
    Hi @Lars-Olof Thid

    OK . I am sorry if this is asking you to repeat something you have already done. Firstly a card with maps on it taken from one TT and put into another TT will not display the maps on the new device. The maps are tied to the serial number of the device they were supplied with or bought for.

    From what you are saying it suggests the the Card still has the Tomtom Formatting on it that was done by the other unit so it will not work as it has been tied to the old units serial number when formatted.

    You should be able to put the Card in a PC and do a full Format to Fat32. Do not do a quick format or agree to it being formatted as before case that is leaving the old Tomtom formatting on it . This should restore the card to how it was originally sold. Then it should be able to be formatted in the device. If this does not work then my next move would be to try another new card.

    Doug
  • Lars-Olof ThidLars-Olof Thid Posts: 13 [Master Explorer]
    edited August 6
    Hi @DougLap.

    The memory card is the one that was originally installed in my friends device when I received it to update the maps for him and it has only been used with his device. I have never put it in any device other than my PC for formatting purposes.

    Any Tomtom information that may have survived not one, but two full formats, should contain the serial number of that device.

    I will try to format the card to NTFS (full format) and then re-format it to FAT32 (again full format) to see if that changes anything.

    Thanks for your help. Much appreciated!

    EDIT: Well, it turns out that the only option available in the SD Card Association Formatting Program for PC is the Overwrite fotmatting that I've used when I have formatted the card before... :-)

    EDIT 2: Well, something seems to be FUBAR....
    I did an Overwrite formatting using the SD Card Association Formatting Program for PC, however, when I looked at the card the Tomtom files were still there after formattting the card...

    It seems like the formatting doesn't really wipe the card like I thought it would...

    I have formatted the memory card to NTFS in Windows. Trying to format it back to FAT32 in windows will however fail for some reason, so I'm now formatting it with SD Card Association Formatting Program for PC.
  • Lars-Olof ThidLars-Olof Thid Posts: 13 [Master Explorer]
    edited August 6
    LOL... This is getting beyond ridiculous...

    OK, while I was formatting the SD card I did a factory reset of the device and when it booted up it said it had no maps installed on it, so I installed the Northern Zone for Europe. Once that was done I turned the device off and installed the SD card and turned the device back on. When I started MyDrive Connect I noticed it said there was only about 12 GB of free space which seems odd, so I clicked on the map icon and the window expanded and showed me what's installed on my device... By the way, I still can't format the SD card as it already has Tomtom's file system. HOW can it have the Tomtom file system?????? I just formatted it to NTFS and the formatted it with SD Card Association Formatting Program for PC!!! It should be completely erased!!!

    Guess what...

    There's a problem with the map installed on the SD card?

    How on earth can there be a problem with the map on the SD card??????

    I have just wiped the card, factory reset the device and I have not even tried to install a map on the SD card yet. Aaaaarrrrgggghhhhh!!!!!!!!
Sign In or Register to comment.

Who's Online in this Category0