start 50 locked on tomtom black screen — TomTom Community

start 50 locked on tomtom black screen

I put video of the beginning, it does not go beyond the first screen of tomtom and the bells do not sound

Another video trying to reset. Continuously pressing the start button. It never goes past the tomtom screen. It reboots.



  • LAURE123LAURE123 Posts: 1,632
    edited July 2020
    Hi @yayonando

    Charge your device with a main charger, that of a Smartphone/Iphone/Tablet 2 Amps will suit, at least for at least 2 or 3 hours. The battery must be fully charged and able to hold charge for a minimum time. Maybe a failed battery.
    Your device still connected to the main charger do a Soft Reset.
    Soft Reset ==> Device switch on, press and hold the On/Off button until you hear the drum sounds. This can take 30 seconds or more. The device restarts. If you see a black screen with white text, hold down the button until you hear the drum sounds.

    Do you have a micro-SD card installed in the device to store maps or tracks?
    Whith the device switch-off, remove this micro-SD then switch-on your device and do a Soft Reset. The same problem presists?

    If the device starts you will have the message "No map" in red banner if the EU map was on the micro-SD.
    Device switch-off again, put the micro-SD back in, push it firmly into its slot, you must have a spring effect. Switch-on the device and redo a Soft Reset.
    If the problem comes back your micro-SD is probably at the origin of your problem maybe it is damaged, to change.

    To contact TomTom customer service by email or chat if necessary, find out how to do it here. The phone service is stopped.

  • yayonandoyayonando Posts: 4 [New Seeker]
    thanks for answering. @LAURE123

    More or less they always answer the same thing.

    The problem is that the drums do not sound. The tomtom doesn't get to that point in any way. It stays on the tomtom screen and does not go from there.

    The reset is not made
  • LAURE123LAURE123 Posts: 1,632
    Hi @yayonando

    To launch the Recovery Mode, reinstall the internal software of the device, you should at least see a black screen with white text lines, the BIOS of the device. It is obtained by holding down the On/Off button. and you don't have it on your videos.

    Apparently you have contacted TomTom customer service who have no other solutions for you.
    Sorry for you, if with the battery charged and the micro-SD removed you don't get better, I don't see what else to do either.

  • yayonandoyayonando Posts: 4 [New Seeker]
    thanks @LAURE123

    my device can't load the BIOS from what i see. the drums never sound or the white letters.

    I don't know how it happened, but for updating with my drive connect, I ran out of device.
  • VikramKVikramK Posts: 12,208 Moderator
    Hi @yayonando

    Welcome to the community!

    Could you send me the serial number of your device through a private message, please?

    Thanks, Vikram
  • SewerjackSewerjack Posts: 1 [New Seeker]
    Curious if you have found a solution for your problem. Hooked my GO 50 up for the first time yesterday and after it updated it is doing the same exact thing your video shows yours is.
  • DougLapDougLap Posts: 8,254
    Hi @Sewerjack

    Assuming you have tried the suggestions in the above posts then hopefully @VikramK may be able to offer a solution on Monday. Look back then.

  • Flemo74Flemo74 Posts: 1 [New Seeker]
    Mine doing the same also. I manage to get to the BIOS and do the recommended 3 presses of the on/off switch in quick sucession but never get the cog wheel :-(..8 times I have tried now. It just goes back to the black screen everytime. Very frustrating, not had it long either x
Sign In or Register to comment.

Who's Online in this Category0