TomTom GO 520 update not showing

Adrian_GO_520 Registered Users Posts: 4
Novice Seeker

I purchased the GO 520, with Lifetime World Maps, Lifetime Speed Cameras and Lifetime Traffic. I can't update neither the device or the maps.

If I go to "Updates & New Items" it shows "Your TomTom GO 520 is up to date!".

When I go to maps, I can see current map as Europe, if I go to Choose another map, I get Europe (975.7679), and if I go to Add a Map, I get only the Available space, nothing else.

In Settings - System - About:
- Application version from 22/09/2016.
- Installed maps: 'Europe' v975.7679 (Released 07/2016)

I also tried connecting it to the PC and use TomTom Connect, but being a Wi-Fi version it seems that option doesn't exist anymore.

Other things that I tried:
- Connecting to a different Wi-Fi
- Settings - System - Reset
- Waiting 24 hours in case of any delays

Tried reading the other topics and also researching on the internet, but I couldn't find a solution for this issue.

I am eagerly waiting to see if there is a solution or I should consider returning the device.

Thank you for your help!


  • DougLap
    DougLap Posts: 10,024
    Hi @Adrian_GO_520

    It could be that the settings on the Tomtom Servers may need sorting. Hopefully @VikramK will pick this up tomorrow and sort them out if necessary.. Look back here to see what he has to say. One thing that particularly suggests it is the settings is that you are not being offered any other maps.

    You only need to use your PC with My Drive Connect running on it if your Wifi signal is poor or you have no Wifi and the PC is on a wired connection.

    When you do get offered the world maps to chose from then I recommend that you find a small map like Iceland, Venezuela or Iraq and load one of them onto your unit. It will be added to the internal memory and should be left there in case when you are updating our main map there is a problem and you lose the map. You need a map on the device to be able to start it up so the little map will enable you to run the device normally and sort the problem out.

    Should you want to add a number of maps then you will need a Micro SD Class memory card which I suggest is either 16gb or maximum 32gb. Get a Sandisk, Samsung or similar main manufacturer as some of the lesser known cards have had the odd issue.
  • Adrian_GO_520
    Adrian_GO_520 Registered Users Posts: 4
    Novice Seeker
    Hi @DougLap

    Thanks for the info and the quick reply!

    I hope the update problems can be solved on the back end like you suggested, as that is the main problem I have. Following that, the info like the trick with adding a small map might come in handy, thanks! Also, good to know not to go over 32 Gb on the micro SD card.

    I'll keep an eye on this topic to see the updates.

  • VikramK
    VikramK Administrators Posts: 14,273

    Hi Adrian
    Welcome to the community! Your GO 520 does not have the latest firmware installed. That is the reason the lastest map of Europe is not offered for download.

    I would suggest that you contact the customer services to help you with this. We also have a ticket which is under investigation for this issue.

    Thanks, Vikram
  • Adrian_GO_520
    Adrian_GO_520 Registered Users Posts: 4
    Novice Seeker
    Hi @VikramK

    Thanks for the reply. I couldn't find direct contact to customer service. Is it done through Bongo?

    Also, from what you've seen before is this fixable once I contact support or a long and tedious process with no guarantee in the end?

  • Adrian_GO_520
    Adrian_GO_520 Registered Users Posts: 4
    Novice Seeker
    Okay my bad regarding the contact, I found the post on how to contact them. I will get in touch when the live chat opens. Thank you for your help, hopefully this will get sorted.
  • Amitboibanbu
    Amitboibanbu Registered Users Posts: 1
    New Seeker
    Hi Adrian.. I m on the same exact boat issues is exact mirror copy of yours. only available map is Europe (975.7679). Can't add another map ..when I try to add, it just shows available space.. did soft reset
    ...did factory reset.. added SD card.. still the same

    My question is did you ever manage to resolve this? If so,.how?
    Much ppreciated
  • YamFazMan
    YamFazMan Posts: 21,132
    Welcome to the site....
    Due to COVID-19 the phone service has been suspended
    For Tomtom Support Email or Chat lines...(Monday to Friday Normal Office Hours)
    The way of contacting Customer Services has changed

    The official way to Contact Tomtom Support.....

    Stay Safe... ATB YFM