Rider 550 Basemount wiring

shibbycribby
shibbycribby Registered Users Posts: 2
Apprentice Seeker
Hi,

I'm currently wiring up my 550 rider base mount. I'm just wondering whether the cable supplied is fused as I can't see anything on the cable side unless its embeded into the connection collar or somewhere into the base itself. Does anyone know if it does? Or do I need to add an in line fuse separately?

Thanks

Answers

  • YamFazMan
    YamFazMan Posts: 21,133
     Superuser
    edited July 2020
    Hi
    @shibbycribby
    Welcome to the site
    I have fitted a 1Amp Inline fuse on my setup
    The Mount is fused with a difficult to replace surface mounted fuse on the Printed Circuit Board....
    I have fitted a 1Amp Inline fuse on my setup
    Don't use an earthing point on the forks or the headstock you may/will get a lousy Earth Connection back through the Head Stock Bearings....

    Stay Safe... ATB YFM
  • shibbycribby
    shibbycribby Registered Users Posts: 2
    Apprentice Seeker
    Thanks YamFazMan, so you think 1 amp should be enough? I've read different numbers on the amp draw the tomtom needs to draw. I was going to earth back at the main earthing points under the seat on my bike so shouldn't be an issue on that front. Seems strange TomTom doesn't include a proper replaceable fuse as part of the standard cabling considering the cost of the unit.
  • freebass_2004
    freebass_2004 Registered Users Posts: 1
    New Seeker
    Assuming that TomTom hosts this site, I am disturbed that they don't provide the information everyone on the internet seems to be asking. Specifically: What rating fuse is in the Rider 550 and exactly where is it located both physically and in the circuit ?
    I don't think this is a big thing to ask.
    I have tried to find a customer support contact email address without success and I have telephoned the number given ( 1300135604) after an internet search.

    This is poor customer service TomTom. Here is a chance to correct the matter.

    Kindest regards & I love the Rider 550
  • YamFazMan
    YamFazMan Posts: 21,133
     Superuser
    edited February 4
    Hi
    @freebass_2004
    Welcome to the site
    Yes, there is a fuse on the Printed Circuit Board inside the Mount, it is one of the tiny Surface Mounted type fuses soldered to the PCB....
    If you haven't got the necessary precision soldering equipment and skills it would be difficult to replace....
    I used an inline fuse fitted to the power cable when I installed the Rider 550 Mount....
    Maybe useful....
    See... https://discussions.tomtom.com/en/discussion/comment/1727007/#Comment_1727007
    _________________
    End....
    _________________

    The phone service has been suspended (Indefinitely)
    The way of contacting Customer Services has changed
    For Tomtom Support Email or Chat lines...
    (Monday to Friday Normal Office Hours)
    Chat… Will be available during Normal Office Hours
    Email… Will be available outside of Normal Office Hours

    Step by step tips when Contacting Tomtom Support....
    Here... https://discussions.tomtom.com/en/discussion/comment/1771083/#Comment_1771083

    Stay Safe... ATB YFM

  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    The fuse in my mount is 1.5A.