I can't see speed camera anymore [go 520 Italy] — TomTom Community

I can't see speed camera anymore [go 520 Italy]

since I updated to last map speed camera disappared, I can only see Charging Station. I tried soft and hard reset but nothing changes. In my www.tomtom.com/it_it/account/details.html ->Installed on your device there is olny Charging Station Versione corrente: v14.
How I can solve this?

Best Answers

  • campemcampem Posts: 3 [Apprentice Seeker]
    Accepted Answer
    thanks,
    the problem seems solved.

Answers

  • DougLapDougLap Posts: 5,569
    Superuser
    Hi @campem

    Have you checked in Warning and Sounds that Cameras and Hazards is turned on. Its just under the heading Warnings.

    Doug
  • campemcampem Posts: 3 [Apprentice Seeker]
    Hi Doug,
    yes I do, it's all turned on.
  • DougLapDougLap Posts: 5,569
    Superuser
    Hi @campem

    Thank you. Lets see what @VikramK has to say after he has checked the settings for your unit on the TT Servers etc. Look back here later.

    Doug
  • campemcampem Posts: 3 [Apprentice Seeker]
    Accepted Answer
    thanks,
    the problem seems solved.
  • DougLapDougLap Posts: 5,569
    Superuser
    Hi @campem

    Glad you are sorted.

    Doug
  • StoneHeadStoneHead Posts: 3 [Apprentice Seeker]
    Hi, sorry to jump in. Mine have stopped working as well on my TomTom Go 520.
  • DougLapDougLap Posts: 5,569
    Superuser
    Hi @StoneHead

    Try this then connect it to your phone for the Traffic data. It should also pick it up if it is connected to your Wifi..



    Doug
  • StoneHeadStoneHead Posts: 3 [Apprentice Seeker]
    DougLap wrote: »
    Hi @StoneHead

    Try this then connect it to your phone for the Traffic data. It should also pick it up if it is connected to your Wifi..



    Doug

    It’s not traffic that’s stopped, it’s speed cameras
Sign In or Register to comment.

Who's Online in this Category0