Why won't Tomtom Home v2 install on my mac? — TomTom Community

Why won't Tomtom Home v2 install on my mac?

I see from other posts that many users are experiencing issues updating Tomtom Home on their Apple devices because of an issue with javascript.

However I don't even get that far - once I have downloaded the package and double-clicked I get the message 'FAILURE' and 'Installation cannot proceed, as not all requirements were met.'

I get no more information than that. So I am unable to continue using and updating my device with a previous version of Home because it needs updating and yet when I try to update the installation package won't let me.

Not a great situation really. Is there a solution? I'm running MacOS Mojave 10.14.6.


  • VikramKVikramK Posts: 12,678 Moderator
    Hi @trikke_d

    Welcome to the community!
    Could you report this to our customer service with a screenshot of the error message, please?

    Thanks, Vikram
  • szasboszasbo Posts: 1 [New Seeker]
    Same problem here (see attachment).
    Mac mini late 2012 2,5GHz 1TB SSD 16GB RAM macOS Mojave.
    I'm waiting for you.0qmr9hkqpu1z.jpg
  • mixericmixeric Posts: 2 [Apprentice Traveler]
    edited July 2020
    Same problem..
    VikramK wrote: »
    ..Could you report this to our customer service with a screenshot..
    Yes.. last thursday.. but no answer :/
  • thomaA933thomaA933 Posts: 1 [New Seeker]
    I tyr to install the latest version of the TomTom Home on my macbook air with macOs Catalina 10.15.5.
    When i try to start the installer I get this error: "The installation cannot continue because all the requirements are not met."
    How can I fix this?
  • thomaA933thomaA933 Posts: 1 [New Seeker]
    I also got this problem...... Can somebody fix it? :#
  • OnkelpazuzuOnkelpazuzu Posts: 2 [Apprentice Traveler]
    Same here. I run Mac Os Mojave (10.14.6) and get the same message. Very annoying, I'd like to update my Tomtom.
  • dandygdandyg Posts: 1 [New Seeker]
    Same problem here, using Mac OS Catalina 10.15.5 Is anything being done about this?
  • KRDHKRDH Posts: 1 [New Seeker]
    same problem here, running OS 10.14.6. pretty bad that there is no solution for a common problem two weeks after the first message
  • mixericmixeric Posts: 2 [Apprentice Traveler]
    I have report this problem to support, but is no solution :s
  • daviefdavief Posts: 2 [New Seeker]
    I'm having problems with TomTom My Drive Connect and my MacBook and having to use an old Windows based PC.
  • trikke_dtrikke_d Posts: 10 [Master Explorer]
    VikramK wrote: »
    Hi @trikke_d

    Welcome to the community!
    Could you report this to our customer service with a screenshot of the error message, please?

    Thanks, Vikram

    Hi Vikram

    I reported the error via Twitter DM and was told the matter would be escalated, but since then there has only been silence.

    My device has been rendered obsolete by a botched Home update and I am not alone. A swift solution would be the preferable option.

  • remy5remy5 Posts: 1 [New Seeker]
    I have the same problem !
    On Mac OS 10.14.6.
    What is the solution ?

  • trikke_dtrikke_d Posts: 10 [Master Explorer]
    Okay, here is the response from the so-called 'escalation' from the Tomtom tech team:

    "Thank you for your patience. I have had an answer from our tech guys, the issue comes from a faulty installation of the JDK package, please see the following:
    - First uninstall TomTom completely (select Mac OS): https://help.tomtom.com/hc/en-us/articles/360013901760-Reinstalling-TomTom-HOME
    - Then uninstall java JDK from your computer: https://java.com/en/download/help/mac_uninstall_java.xml

    Then reinstall TomTom Home, and re-download and re-install the JDK package.

    All of you Mac users experiencing the same issue will be acutely aware how half-hearted this response was. Clearly deleting Tomtom and JDK and then performing the exact same installs would result in the same error message.

    On top of this the advice was to install Tomtom first, followed by JDK!? How would this work if Tomtom is reliant on JDK being installed?

    It is about time Tomtom took this issue for us Mac users seriously and looked into fixing the problems. All of us now have effectively redundant devices and I suggest that we group together and insist the issue is resolved swiftly or we demand some sort of reparation from Tomtom.

    This is simply unacceptable customer service care.
  • rupertdrupertd Posts: 3 [Neophyte Traveler]
    Did anyone get an answer on how to resolve this for Mac? I fancy becoming a 'Karen' and demanding to speak to the manager
  • trikke_dtrikke_d Posts: 10 [Master Explorer]
    rupertd wrote: »
    Did anyone get an answer on how to resolve this for Mac? I fancy becoming a 'Karen' and demanding to speak to the manager

    No, what they do is go silent and stop replying.

    I've contacted them here, on Twitter and Facebook - they just ignore you if you have an issue they can't solve.
  • PhilC1PhilC1 Posts: 2 [Apprentice Traveler]
    edited September 2020
    I have the same issue - I have a Mazda NB1 system and cannot update my TomTom Home software on my Mac (I'm on Catalina 10.15.6). I have emailed TomTom directly this evening - but does anyone have an update about this issue? It's ridiculous if this is still unresolved.
  • trikke_dtrikke_d Posts: 10 [Master Explorer]
    Here's the latest communication I had via twitter with TomTom:
    Hello Richard,
    It is no longer possible to use TomTom Home on Mac OS Catalina because Apple has restricted support for 32-bit applications on its system.
    This is an announcement that was made with the release of Mac OS Mojave 10.13 (system before Catalina).
    From now on, 32-bit applications do not work natively on this system.
    Only 64-bit applications are compatible on this one. It is a restraint.
    However, it is possible to add libraries to the system to run 32bits applications. In general, these modifications are reserved for developers, computer-savvy people or people who could absolutely need these applications.
    We are working on a compatible version which allows to work around the problem but unfortunately as long as the application is not completely rewritten in 64 bits, there will always be problems.
    I advise you if you have the possibility to use Windows 10, which still accepts both architectures.
    You should also know that Mac OS Catalina will normally be the very last Apple system to accept 32-bit applications.

    It's the usual bluster and doesn't explain why it didn't work in Mojave.
  • WindlipperWindlipper Posts: 6 [Master Explorer]
    I need to update my TomTom rider and am having the same problems when trying to install TomTom home on my Mac - "Installation cannot proceed, as not all requirements were met." I'm glad I've found this link after hours of trying to overcome the problem to save me struggling any further. Doesn't seem to be any point in speaking to customer support.
    I am due to update my device but unless this issue is sorted out pronto Garmin here I come!
  • VikramKVikramK Posts: 12,678 Moderator
    edited September 2020
    Hello @Windlipper,

    Have you tried the troubleshooting steps I advised in my comment here

    Regards, Vikram
  • BistosBistos Posts: 1 [New Traveler]
    I have Mojave 10.14.6 and followed the instructions and cannot install Tom Tom Home.
    All I wish to do is update my maps for my Carminat Renault.
    When will you have a solution to yours and our problem?
  • CalijoCalijo Posts: 1 [New Seeker]
    edited October 2020
    Hi! I have also problem with installing Tomtom Home on a MacBook Pro with macOS Sierra, 10.12.6
    It says I should remove the JDK package and replace it. With an older version!!! That is not good for security reasons. When will you fix this issue? I have an old rider which cannot be updated because your software sucks and don't match with Macs.
  • JeanCarminatJeanCarminat Posts: 1 [Novice Seeker]
    I have the same problem installing the latest TOMTOMHOME version;Problems started with the release of iOS Mojave; error message was given by my Mac that 32 bits apps. no longer are supported; like so with tomtomhome. From that moment on I was no longer able to update my navigation. Recently I deinstalled the old version of tomtomhome and tried to install the latest version but I get following message:

    " A supported version of JDK must be available on your computer to install TomTom HOME for use.
    This process installs and configures the minimum required version of JDK (jdk 1.8.0_152) to complete the setup " ; after confirming this step following error message appears:

    " Installation cannot continue because not all prerequisites have been met."

    It looks like there would be something wrong with the java script but in my opinion the problem is the 32 bits issue of the tomtom software!!??

    Who has a solution for this issue?
  • WindlipperWindlipper Posts: 6 [Master Explorer]
    VikramK wrote: »
    Hello @Windlipper,

    Have you tried the troubleshooting steps I advised in my comment here

    Regards, Vikram

    Yes all tried, no different, TomTom relegated to cardboard box in my garage! I've spent enough of my life trying to sort it out. Garmin on order.
  • cfox9999cfox9999 Posts: 4 [Apprentice Traveler]
    I have the same problem and TomTom HOME did not work for months under Catalina. Now again with Big Sur. However, I have paid a three year subscription for the map update service. TomTom is simply not delivering what I have paid for.

    I created a case at the online dispute resolution center of the European Union (https://ec.europa.eu/consumers/odr/main/index.cfm?event=main.home2.show&lng=DE). That sends an official request to TomTom to answer on a claim by a consumer regarding an online purchase. No idea where this will lead to, but it is a try worth.
  • YamFazManYamFazMan Posts: 20,053
    Maybe useful... How to Run 32-Bit Apps in macOS Catalina
    Here... https://uk.pcmag.com/old-news/123012/how-to-run-32-bit-apps-in-macos-catalina

    Stay safe... ATB YFM
Sign In or Register to comment.

Who's Online in this Category0