Connecting my TomTom Spark to TomTom Sports Connect — TomTom Community

Connecting my TomTom Spark to TomTom Sports Connect

DuncanPriorDuncanPrior Posts: 4 [Apprentice Seeker]
I have just sent the logs to you. The reference is XX1594468375.

I re-installed Sports Connect, ran the driver cleanup utility, ran USBDreview - all OK. I have tried this on more than one laptop as well.

I have never been able to connect my watch to the computer. Sports Connect only displays the message 'Connect Your TomTom Device' and nothing happens.

Regards, Duncan Prior

Answers

  • DuncanPriorDuncanPrior Posts: 4 [Apprentice Seeker]
    And now I can't connect via bluetooth until the update to the watch takes place.
  • tfarabaughtfarabaugh Posts: 16,677
    Superusers
    A few things to look at (and I apologize if some are very basic, but it is best to get past the obvious issues first):

    1) Are you plugged directly into the machine and not a hub?
    2) Does the port work, can the computer detect other devices (like flash drives) in that port?
    3) Is the watch firmly snapped into the cradle and the USB plug firmly in the port?
    4) Is the USB port free of any debris or blockages?
    5) Is the Connect software running (is there an icon for it in the notification area)?
    6) Did you install Sports Connect, not MyDrive Connect? It is downloaded from tomtom.com/123
    7) Do you have administrator rights to the computer?
    8) Is a firewall or antivirus running that is blocking the software from connecting to TomTom (try turning them off before docking the watch)?
    9) Does the computer have a good Internet connection (Internet is required to sync)?
    10) Can you try installing it on a different machine to determine if it is an issue with the computer versus the watch?

    Is there any damage to the pins in the charger or the contacts on the watch? If any of the pins are bent or deformed straighten them out with a pin and make sure the contacts on the back of the watch are free of tarnish or grime. Also make sure it is fully snapped into the cradle.
  • DuncanPriorDuncanPrior Posts: 4 [Apprentice Seeker]
    I tried all these things, including a different computer. I have just temporarily turned off the firewall on my laptop and that had no effect. I have run software to check that both USB ports work and they do. The cradle works because the watch is charging through the USB connection now and the internet connection is excellent. I'm definitely running mysports connect. I've never managed to get this to work. What do the logs say? Regards, Duncan
  • tfarabaughtfarabaugh Posts: 16,677
    Superusers
    edited July 2020
    This s a user forum, not customer support, no one here can look at your logs. For that you need to contact support directly through chat or email. The watch will charge even if it will not connect as there are 4 pins on the dock and two are for power and two are for data. Check that all 4 pins are free and not stuck down and that there is no tarnish on the watch contacts.
  • DuncanPriorDuncanPrior Posts: 4 [Apprentice Seeker]
    OK, I see.
Sign In or Register to comment.

Who's Online in this Category0