Lack of Traffic Service

Mike Miles
Mike Miles Registered Users Posts: 5
Apprentice Traveler
Hi, have just bought a secondhand Go 5200 with allegedly lifetime traffic, but the traffic only seems to operate on my home wifi - as soon as I'm down the road the icon shows a cross - not connecting. The service shows as active in the settings... Any thoughts? My previous Tom Tom needed a traffic subscription, but is disconnected from my account now - is there some confusion with that? Would really like the traffic service to work!

Answers

  • DougLap
    DougLap Posts: 9,833
    Superuser
    Hi @Mike Miles

    Try a Soft Reset Ie turn the unit on and when ready Hold the On/Off button fro about 20 seconds plus until you hear the Drumroll Sound then let the button go. The unit will restart.

    If that does not work then try Reset Device. Ie Menu/Settings/System/ Reset Device. This will return the unit to Out of the Box except the current Operating Software and Map versions will not be affected.

    Before you do the latter reset log into your account on the MyDrive Website ad check that all your my Places, any 3rd Party POI files and Routes on the device are backed up there. When you set the device up again they will sync back to your device when it logs into your account.

    Doug
  • Mike Miles
    Mike Miles Registered Users Posts: 5
    Apprentice Traveler
    Thanks Doug, sadly no joy :-( Same result after both soft reset and a full factory reset. It's fine starting up at home, but half a mile en-route the traffic and my-drive show as disconnected... If I had any hair left I'd be tearing it out!
  • DougLap
    DougLap Posts: 9,833
    Superuser
    Hi @Mike Miles

    Hopefully @VikramK will pick this up on Monday and check your account settings on the TT servers and sort them if there is a problem.

    Look back here then.

    Doug
  • VikramK
    VikramK Administrators Posts: 13,758
    Moderator
    edited July 2020
    Hi @Mike Miles

    Welcome to the community!
    I don't find any issues with the services or subscriptions for your TomTom. As you have already tried the steps suggested by Doug, I would recommend that you report this to the customer service.

    Regards, Vikram