lost maps rider v2 — TomTom Community

lost maps rider v2

keith173_keith173_ Posts: 3 [Apprentice Seeker]
I have recently acquired a new unused rider v2 2013 . When switched on it was showing the red cross . After following instructions I appear to have deleted the maps . On trying to update it shows no updates available . can anyone help?

Best Answer

Answers

  • VikramKVikramK Posts: 9,512 TomTom Moderator
    Hi @keith173_

    Welcome to the community!
    Please do a soft reset and check for updates in TomTom HOME.

    Regards
    Vikram
  • keith173_keith173_ Posts: 3 [Apprentice Seeker]
    Hi Vikram , I have tried as you suggested. It loaded a number of gps Quick fixes on to my device but there are still no maps available . I think my device is a rider v4 by the way .

    thanks Keith
  • keith173_keith173_ Posts: 3 [Apprentice Seeker]
    Hi Vikram ,
    Good news, the maps appeared in the update section and I have now uploaded them . Everything is working fine now . Thanks for your help .


    Keith
This discussion has been closed.

Who's Online in this Category0