Unable to install maps — TomTom Community

Unable to install maps

PromishPromish Posts: 4 [Apprentice Seeker]
Hi,

I checked my GPS today, had an update. When i tried to install it the old map was gone. Now every time i open my device it says no map found and i need to add at least one map before i can use my device. I tried to install the Ocenia (Australia map) in both on my GPS and memory card (32 GB). It reaches 99% and i get an error to contact support. I have tried it about 30 times to update it, formatted the memory card, did everything. NO SUCCESS.

Can someone please help. I have tried everything and visited several threads in this forum

Device details are: Tomtom GO Supreme
Date of purchase: 11 March 2019

Thanks

Answers

  • DougLapDougLap Posts: 7,733
    Superuser
    Hi @Promish

    Try a Soft Reset ie with the unit on the hold the On/Off button down fro about 20 seconds plus until you hear the drumroll sound then let the button go.

    When the unit restarts take the Memory card out and try and add the Venezuela map as it is very small. If that works then start trying to load the maps you need.

    When you formatted the memory card in your PC did you do a Quick fromsat to Fat32 if so then do it again but as a full format as the quick format does not do what you need done.

    Doug
  • PromishPromish Posts: 4 [Apprentice Seeker]
    @DougLap

    Thanks for your reply. I tried your method of soft reset but with no success. I am also not able to select any other maps than Oceania (673 MB) and South Asia (1.7 GB). I have tried to add both maps on both GPS and memory card no success.

    Tried the tomtom support live chat, no success.

    Seems like i am stuck now.
  • DougLapDougLap Posts: 7,733
    Superuser
    Hi @Promish

    You don't say in your profile so where are you as for example in the USA the Supreme comes with World Maps.

    Doug
  • PromishPromish Posts: 4 [Apprentice Seeker]
    Hi @DougLap ,

    Thanks for your message. I tried everything. There is no option of me to select any other map than Ocenia and Asia. Did factory reset, made a different account and selected home country as US, removed memory card, tried to select US as the country but no luck. there is literally no option for me to do anything.

    After all this, now i cannot even access the menu as it says i need atleast one map before i can use my device. There is now no way i can click on the menu.

    Such a bad experience with this so called high end tomtom GPS device.
  • DougLapDougLap Posts: 7,733
    Superuser
    Hi @Promish

    Hopefully @VikramK or @lampard can have a look at your account and the logs for your unit. They can check if any changes are needed re maps etc.

    Look back later to see what they suggest.

    Doug
  • PromishPromish Posts: 4 [Apprentice Seeker]
    Hi @DougLap / @VikramK / @lampard

    I have managed to get the Venezuela and few other maps(Hongkong, Algeria, Neatherlands etc ) loaded on my device. It's just the Australian/Oceania map i am unable to download. I thought it might be the size so i downloaded Canada & Alaska ~0.97 GB and it works. I have got about 13 Gigs free on my GPS and a 32 GB memory card. However, map of Australia ~577 MB or Oceania ~ 677 MB which is a bit high in size goes to 99% and then the same error to contact support. But, the internal memory should be more than enough for the install.

    Having said that, I have an update i.e. POI update: Charging Station~ 88 MB that pops up under my "Updates and New Item" which i have been trying to download without any success. It reaches about 96% and again asks me to contact support as the update fails.

    I tried to factory reset/soft reset multiple times.

    Following are the maps i have download both on my GPS and/or memory card with success.

    - Canada and Alaska ~ 0.97 GB (Memory Card)
    - Hongkong ~ 50.06 MB (Memory Card)
    - Neatherlands - 258 MB (Memory Card)

    - Algeria ~66.30 MB (GPS)
    - Venezuela 30.16 MB (GPS)
    - Italy ~ 853 MB (GPS)

    I have got a good internet connection and i have even tried to use my 4G connection from my phone for the update by tethering. No success.

    Seems like i can use it all over the world besides Australia/New-Zealand.

    Any help to resolve this issue would be great as i don't know what to do.

    Cheers
    Promish
Sign In or Register to comment.

Who's Online in this Category0