6200 Proffesional not powering on — TomTom Community

6200 Proffesional not powering on

Firstly hi and hope all is well... My device started randomly turning off the other day and sometimes wouldn't turn on for ages. Then boom, it starts. So whilst I was getting these weird episodes, I decided to update device and reset it. Now the blimmin' thing will not turn on properly. All I am getting is the TOMTOM name for a couple of seconds and then it goes dead. I have had it on charge for hours in my house. I've tried various cables (including the original one). Unable to follow troubleshooting guide as the thing won't even power up. I'm at a dead end with it now. I'm kind of thinking the battery is shot. Any ideas on what to do? Thanks.

Answers

  • rider1riderrider1rider Posts: 625 [Revered Pioneer]
    chat or call with the customer service on monday.
  • JON8HJON8H Posts: 4 [Apprentice Traveler]
    Not a disimilar problem. After it having been connected to the PC for a cpouple of days when I truy and switch it on a red flashing batter comes on the screen.
  • DougLapDougLap Posts: 7,711
    Superuser
    Hi @JON8H

    The level of charge provided by a USB socket on a PC is small so If you have an Apple iPhone or mains power plug which takes the USB cable then I would try that as that will provide a much bigger charge. If the battery has been allowed to go flat a few times then it is possible it has failed as Lithium batteries do not like that .

    Doug
  • JON8HJON8H Posts: 4 [Apprentice Traveler]
    Doug - I wish I had been told that at the start, but heard nothing until these problems started. Many thanks for your help.
  • YamFazManYamFazMan Posts: 19,232
    Superusers
    edited November 2020
    Hi
    @JON8H

    The Previous NAV4 and Latest (NAV5 Wi-Fi) devices are quite power hungry and can go into "Power saving mode" if not supplied with enough power
    Are you using the Tomtom supplied cable and Tomtom supplied Power Adapter
    The Charger Adapter and USB Cable supplied by Tomtom WILL run and charge the device at the same time

    Many 3rd parties Mismatched Charger Adapters won't run and charge the device at the same time
    See... It's not simply a power thing.....
    https://discussions.tomtom.com/en/discussion/comment/1182024/#Comment_1182024
    _____________________________________

    When the device is In use they are designed to be always connected to a power supply
    The Tomtom supplied Power Adapter is rated at 5Volts 1.2Amps
    Even after you have recharged the device externally via a mains charger, when in use in the vehicle, they will still require being connected to a Tomtom supplied Power Adapter (Or a proven suitable 3rd party Power adapter)
    ______________________________________

    (1)... Do NOT attach them to a dashboard USB port in your vehicle as they normally only supply 500mAmp (0.5Amp) and are for data transfer and not supplying power: See... Note (1) & (2)

    (2)... Using a NONE Tomtom 3rd party underpowered or a mismatched cigarette lighter charger can cause the device to go into Power Saving Mode: See... Note (1)

    (3)... On the Models with a built-in SIM, the reduction of power to the SIM can cause the dropping of the traffic info: Note (3)

    Note (1)... At an (Undisclosed) percentage of battery discharge, the device will try to save its power requirements by dimming the screen and eventually powers off the device... Devices with a built-in SIM Card may also lose Live Traffic services
    Note (2)... A dashboard USB port can also fool a NAV4 Device into entering 'Updating Mode' and display the Connected to your Computer splash screen
    Note (3)... I tried connecting my Tomtom GO 6200 to my Cars USB port, checked the connection status...
    It reports 'Connected over USB' --> 'GPRS (SIM) Disconnected'

    Stay Safe... ATB YFM
  • Dan82Dan82 Posts: 2 [Apprentice Seeker]
    Thanks for replies. I took device back to Halfords and hot a replacement there and then. Cheers.
  • justjujustju Posts: 1 [New Seeker]
    ditto, less than 6 months old and died trying to update now it will not power up at all. 300 quid plus would expect a lot more than this.
  • YamFazManYamFazMan Posts: 19,232
    Superusers
    edited November 2020
    Hi
    @justju
    Welcome to the site....
    Have you tried a Soft/Drum roll restart on the device ??? This restarts the devices Operating System afresh

    RESETTING YOUR NAVIGATION DEVICE
    https://help.tomtom.com/hc/en-gb/articles/360013957499-Resetting-your-navigation-device
    Charge the device for at least 3Hrs….
    (Preferably using something like a Smartphone Charger using the Tomtom USB lead)... Have the device plugged into the power supply while the device is restarting
    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    I use a Soft/drum-roll start after any upgrade large or small.
    It’s also useful to keep in mind for sorting out most minor niggles....

    Stay Safe... ATB YFM
  • DougLapDougLap Posts: 7,711
    Superuser
    Hi @justju

    Just to add to @YamFazMan 's post have you been using the TT supplied Charger unit in the Cig Socket or have you been plugging the cable into a USB socket on the vehicle.

    Doug
Sign In or Register to comment.

Who's Online in this Category0