Go Premium: No Traffic info anymore after one month of use?

enroute
enroute Registered Users Posts: 4
Apprentice Seeker
edited December 2021 in Devices using Wi-Fi®
A month ago I purchased a TomTom Go Premium. I now was promted to purchase a subscription for further traffic information. Hopefully this is an error. If you pay more than €300 for a navigation device you would expect the most vital function being up to date traffic info included.

Best Answer

Answers

  • DougLap
    DougLap Posts: 9,855
    Superuser
    Hi @enroute

    It looks as though you Account has not been set up correctly. Maybe @VikramK can review your account and arrange any changes necessary. have a look back here to see if he responds . Not seen him online today so maybe tomorrow.

    Here are the contact details by country as many have no phone lines available during the current situation.

    https://discussions.tomtom.com/en/discussion/1122389/customer-service-contact-details-during-covid-19-epidemic

    Doug
  • enroute
    enroute Registered Users Posts: 4
    Apprentice Seeker
    Thanks for your thoughts Doug. Unfortunately not only telephone but also the chat are unavailable. The e-mail form does not allow to send the message. (Disabled) Looks they have a real problem with support. My hope is then that @VikramK can offer some help.
  • DougLap
    DougLap Posts: 9,855
    Superuser
    Hi @enroute

    With the email did you get to the page where you could write your message and then it would not go. Took a long time to offer the Email message page to me does it go if you wait long enough.

    Doug
  • enroute
    enroute Registered Users Posts: 4
    Apprentice Seeker
    Hi Doug, in order to send an email you first need to login which did work this morning but now I get a spinning wheel, sitting there for more than an hour now. Maybe they switch this option 'off' outside office hours? This is by the way a complaint I read about in other threads as well. I will try again tomorrow. (Chat option never showed up)
    Jan
  • enroute
    enroute Registered Users Posts: 4
    Apprentice Seeker
    Many thanks! I'm glad you could solve it that easily. A pity it took me several hours to get to this point. (No other options than this forum.) Anyhow, it's solved and that's the main thing.
    Thanks again.
    Jan