The speed and speed limit is not showing on my display, how do I activate this? — TomTom Community

The speed and speed limit is not showing on my display, how do I activate this?

DrawsyDrawsy Posts: 2 [Novice Seeker]
My Rider 550 should show current speed and speed limit and I cannot find a setting to have this displayed when riding?

Best Answer

Answers

  • Bart0Bart0 Posts: 45 [Renowned Wayfarer]
    edited May 22
    True, I experice the same (TT Rider 550). When you are driving a route/ track your device will show your speed and speedlimit. When you are driving without setting a route/ track first, no speed and no speedlimit is shown.
  • DrawsyDrawsy Posts: 2 [Novice Seeker]
    Thank you for your response, correct nothing appears until you reach at least 5mph which was difficult in my back garden! :)
  • Richard_VMCCRichard_VMCC Posts: 7 [Apprentice Seeker]
    edited May 22
    To clarify please, on the Rider 550 how do I display speed limit and current speed in map view when I'm not following a track or route?
  • YamFazManYamFazMan Posts: 17,064
    Superusers
    edited May 22
    Hi
    @Richard_VMCC
    See below... A quote from a previous post of mine
    Note... If you haven't planned a route/track you will need to manually set the zoom to a reasonable level to suite your requirements....
    YamFazMan wrote: »
    Hi
    Out today... Using my GO 520 in the UK
    I drove around without route planned
    Using the 2D, 3D and the North up Overview Maps
    In all three Modes, the device warned of.....
    Exceeding the Speed Limit
    Fixed Speed cameras
    Mobile Speed camera Hot Spots
    Average speed camera zones (Motorway)

    I can see any reason why.....
    Approaching Stationary Queuing Traffic
    Red Light Camera... Wouldn't also Show

    Any 3rd Party POI you have loaded and set to display on the Map... All display the Tomtom generic Icon OK

    I didn't Notice if petrol stations were displayed on the map or not
    _____________________________
    _____________________________

    For general improvement for a NAV 4/5(Wifi) device over the default settings

    Always use a Computer voice...
    Also....
    From the main screen... Tap (.... Menu) -> Setting -> Sounds & Warnings...
    Set... 'Warning Type' to... Read Allowed...
    (Important... Needs a Computer Voice set in the Voices menu)
    Speed Cameras & Hazards... Set to ON
    The next 10 Setting ALL set to Always
    The next 4 Settings ALL set to ON
    The device will now say....
    'Fixed Camera'
    'Mobile Hot Spot'
    Spoken Traffic delays
    Red Light Camera
    Stay Safe ATB YFM
  • Richard_VMCCRichard_VMCC Posts: 7 [Apprentice Seeker]
    Thanks for your reply. :+1:
Sign In or Register to comment.

Who's Online in this Category0