Start 52

MartinsD
MartinsD Registered Users Posts: 1
New Seeker
Hi! Today I bought Tomtom Start 52. This is my second device, the first one is Start 25. MyDrive Connect shows: "Your device is up-to-date!", however installed map is Europe 45+ v.10.30 (not the newest 10.47). Please help with advice, how to get the map, version 10.47
The oldest device Start 25 has map: Europe v10.47

Comments

  • DougLap
    DougLap Posts: 9,833
    Superuser
    Hi @MartinsD

    With the current situation and many working from home it appears that it is taking a little longer for some to get set up right on the TT servers. Hopefully @VikramK will pick this up tomorrow and sort the account out if needed. Look back here then.

    Doug
  • VikramK
    VikramK Administrators Posts: 13,758
    Moderator
    Hi @MartinsD
    Welcome to the community!

    I have asked the team to fix the subscription for your device. Please check updates in MyDrive Connect.

    Regards, Vikram
  • tokunbo
    tokunbo Registered Users Posts: 3
    Apprentice Seeker
    just purchased speed camera updates, took a route past two-speed camera sites
    both ways, nothing, not a peep, double-check all switched on did a soft reset and repeated the trip---- nothing.
    obviously not done something----why to tomtom make this op so complicated.
    Anyone got any ideas ???
  • DougLap
    DougLap Posts: 9,833
    Superuser
    Hi @tokunbo

    With the current situation with people working from home it seems some subscriptions seem to take a while to get allocated to the account. Hopefully @VikramK or @lampard will pick this up and sort your account out if necessary. Look back here tomorrow to see if they respond.

    Doug