TomTom GO 520 radars and POIs — TomTom Community

TomTom GO 520 radars and POIs

cisecaciseca Posts: 2 [Apprentice Traveler]
Good afternoon everyone, I have a problem with my navigator about speed cameras, when I select a destination not all of them come out and sometimes none, it also happens to me with POIs. Does anyone know what it could be ?, because the updates of maps and radars install them for me. Thank you very much to all.

Mod edit: Machine translated from Spanish

Best Answers

Answers

  • cisecaciseca Posts: 2 [Apprentice Traveler]
    edited May 2020
    Good afternoon, thank you very much for your interest in the two colleagues who have answered the question I asked, restart the browser as you said and I have solved it. Thank you very much again you are phenomena.


    Mod edit: Machine translated ( Spanish)
  • YamFazManYamFazMan Posts: 19,445
    Superusers
    edited May 2020
    Hi
    @ciseca
    Google Translate....
    ciseca wrote: »
    Good afternoon, thank you very much for your interest in the two colleagues who have answered the question I asked, restart the browser as you said and I have solved it. Thank you very much again you are phenomena.

    You're welcome, glad you're sorted :)

    Stay Safe... ATB YFM
  • LAURE123LAURE123 Posts: 1,632
    Superuser
    Hi @ciseca

    Thanks for your nice comment. We are only users who have some identical worries... but before you.
    Glad for you that your device works properly again. :)

    Regards.
Sign In or Register to comment.

Who's Online in this Category0