MyDrive Connect Waiting for your device... — TomTom Community

MyDrive Connect Waiting for your device...

KevinPetersKevinPeters Posts: 2 [New Seeker]
edited May 2020 in Map installation
And waiting and waiting...

I am trying to install a map on my Go 400, anything that will fit on the internal memory, in this case the Soiuth West europe map. When I start the process I just get a message on MyDrive saying: "Waiting for Device" and on the device it says "Updating - do not disconnect your device". This goes on for hours with nothing happening. I have tried two different Macs, with a hub, without a hub, different cables, I have updated to the latest version of MyDrive, cleared my cache... Sometimes I am amazed that TomTom still manage to exist with shoddy engineering like this.

Anyway, I would love to put a map on my Go-400. Any suggestions from TomTom?

Answers

  • KevinPetersKevinPeters Posts: 2 [New Seeker]
    I've also tried: a factory reset of the device, putting the old SD card back in the slot, using a Windows 10 machine, removing the device from my account a re-adding it.

    It even hangs now on Your Device is Being Added.

    Shoot me now.
  • YamFazManYamFazMan Posts: 19,263
    Superusers
    Hi
    @KevinPeters
    Welcome to the site....
    If I have a problem with myDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller then Reinstall MyDrive Connect....
    Using the Method Here... https://discussions.tomtom.com/en/discussion/comment/1682074/#Comment_1682074
    ______________________

    Or... Instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program just as effective for giving MyDrive Connect a CPR...
    See... https://discussions.tomtom.com/en/discussion/comment/1686214/#Comment_1686214
    ______________________
    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.
    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

    ATB YFM
Sign In or Register to comment.

Who's Online in this Category0