GO 520 will not start, and my windows PC does not see it. Can anyone help? — TomTom Community

GO 520 will not start, and my windows PC does not see it. Can anyone help?

I purchased a GO 520 on March 19, 2020, and only used it for only 2 trip. Now, it will not turn on, and my Windows 10 PC does not even see it when connected directly (without mount) to the USB port.... it does not show up in Devise manager. I've charged it for over a day via a wall plug, and tried all the trouble shooting tips, but nothing works! Does anyone know how to get it to work, or should I just ship it back?

Best Answer

Answers

  • DougLapDougLap Posts: 6,893
    Superuser
    edited April 2020
    Hi @DavidinNH

    Just to check have you tried charging the unit whilst not in its holder but having the cable plugged directly into the back of the GO520. Also have you tried another USB cable to see if the problem could be the cable.

    Doug
  • DavidinNHDavidinNH Posts: 6 [Apprentice Seeker]
    I have not been using the mount base and connecting directly to the back of the GO 520 with the original cable. Great Idea to try another cable, but it still does not turn on while plugged into the computer with a different cable that I know is good. Does the it require charging for several hours even when plugged into power?
  • DougLapDougLap Posts: 6,893
    Superuser
    Hi @DavidinNH

    Try using an Apple or similar phone mains charger plug which you can plug the USB end of the TT cable into . Gives a much bigger charge than a USB socket on a PC does which only charges enough to run the device but not charge it up as well.

    Doug
  • DavidinNHDavidinNH Posts: 6 [Apprentice Seeker]
    Doug - Thanks, I will try to find an iPhone charging cord, but not sure how to make it work... I believe the iPhones use a long thin connector, at the cell phone, and I don't believe it will fit into my GO 520. Frankly, I don't believe charging is the issue. I have left the 520 charging via a 110 volt wall cube for days, and it still will not turn on. My guess is that the software that tells it how to turn on and boot-up is corrupted. BTW, I just joined this community group and have no idea what a BBcode is. Can you inform me?
  • DavidinNHDavidinNH Posts: 6 [Apprentice Seeker]
    Oh, I know... the iPhone's charging cube plugs into the wall and it accepts a USB plug. So I would just be using the iPhone's charging cube!
  • DavidinNHDavidinNH Posts: 6 [Apprentice Seeker]
    Thanks for taking the time to assist me. Too bad it will need to be replaced! I have informed the vendor of my problems and asked for advise to get it started or it goes back! I have not heard from them yet, but I have until May 30.
Sign In or Register to comment.

Who's Online in this Category0