My Go 5200 satnav screen is stuck on 'No Map Available' — TomTom Community

My Go 5200 satnav screen is stuck on 'No Map Available'

Hi

I was trying to update my TomTomGo 5200 via a wifi connection and half way through the update the screen displayed the message ' No Map Available. You need to add at least one map before you can use your device. When I press the Add a Map button it takes me through to the wifi network connection. When wifi is connected it then goes back to the original message 'No Map Available etc'.

I have tried turning the satnav off and on again but I still have the same problem. I have also tried to update the TomTomGo5200 through MyDriveConnect on my MacBook Air as suggested in one of TomTom's FAQs. When I try to do this by clicking on the satnav icon I just get the 'Update the Easy Way' screen with no other option to update through my MacBook Air.

I have now got as far as connecting to wifi and getting to the Add a Map page but it does not list any maps. It says 'Nothing here? You can buy more maps at tomtom.com/maps.' but I have a lifetime subscription to the maps. Why can I not then download the maps that came with the TomTom Go 5200 when I bought it in November 2019?

I have tried ringing the TomTom support number but I just get an answerphone message saying their office is closed (presumably because of the coronavirus pandemic). I have also emailed their customer support team but have had no reply other than an acknowledgement.

I keep going round and round the same loops, which is extremely frustrating! I would be very grateful for any help. Thanks very much.

Best Answers

Answers

Sign In or Register to comment.

Who's Online in this Category0