Mydrive fails to upload gpx files — TomTom Community

Mydrive fails to upload gpx files

I can create a route in Mydrive, save the gpx to my laptop . I can then upload the gpx file to Mydrive and it shows in MyRoutes fine.
However it will not upload gpx files from other sources eg Ride Magazine routes or a simple gpx file from my laptop that was not created in Mydrive Route planner.
Error message says simple "An error occured - this file cannot be uploaded"
Any ideas or advice please?


  • YamFazManYamFazMan Posts: 20,091
    Welcome to the site....
    Are the GPX Routes private/personal ??? or can you post a link/s to the problem file/s

    Stay Safe... ATB YFM
  • DavshillDavshill Posts: 3 [New Seeker]

    Here you go. Its just the gpx file from the Ride Mag site.
    Cheers YamFazMan
  • DavshillDavshill Posts: 3 [New Seeker]
    I think it might be something to do with the number of way points or segments to the route. A simple A to B route from the same site loads and saves, no problem.
  • PVdbsePVdbse Posts: 1 [Novice Seeker]
    edited May 2020
    Good morning,
    can you check these public available routes from Flanders Fields?

    MyDrive has the same error.
    noticed another thread: tried from MacOS and Win10 ;-(
  • Rob_RRob_R Posts: 56 [Supreme Trailblazer]
    Hi @PVdbse - I did some experimentation with this and found out what the issue is!

    GPX files are just text files that use XML. If you open one with a text editor you can see all the configuration. If you look at the peak district file you will see some generic stuff at the top then three way points defined between <wpt> and </wpt> flags and then a track which is contained between the <trk> and </trk> flags.

    Well it seems that the track in this file has been split up into three track segments i.e. the sections between the <trkseg> and </trkseg> flags. It appears that Mydrive does not like this and gives an error for any file where there is more than a single track segment.

    What I did was create a single track segment by deleting the intermediate </trkseg>/<trkseg> pairs found on lines 1505/1506 and 3953/3954 in the original file. The file then loads.

    I looked at one of the Flanders files and that also had multiple track segments.

    I've no idea why MyDrive does not like multiple track segments but that is what causes the error.
Sign In or Register to comment.

Who's Online in this Category0