I am not able to add my new Rider 500 to my account — TomTom Community

I am not able to add my new Rider 500 to my account

horkonponhorkonpon Posts: 4 [Apprentice Seeker]
Hi all,

I have a problem with the app MyDrive Connect. I use it to add my new Rider 550 to my account but isn't possible.

I use MyDrive Connect under Windows and Mac OS X 10.14 but when I connect the Rider (using the TomTom USB cable) to the PC or Mac, MyDrive Connect only shows a message that indicates that the navigator can receive actualizations via WiFi.

In the FAQ web of TomTom are the screens of the MyDrive Connect. In my case only shows the first screen. When I connect the nevigator the program don't show the second screen.

Thanks in advance
Best regards
Alberto

Answers

  • DougLapDougLap Posts: 5,569
    Superuser
    Hi @horkonpon

    The device is designed to be able to do most functions without the need of a PC. When you attach the device to your PC and get the Screenshot saying do via Wifi it is because you cannot manage updating the device using the PC's keyboard/mouse etc. The connection is only seeking to use the PC's connection to the internet as an avenue for the device to connect to the internet. Theis facility is to cover those that do not have Wifi in their house, maybe for health reasons, or the Wifi download speed is slowish.

    When you connect the device and get the Use the Wifi screen now ignore your PC completely , in fact you could run the My Drive Software in the background and browse the internet if you wanted. Having got the use the Wifi screen use the menu options on your Rider to manage what you wish to do.

    Regarding adding the device to your account if you have input your account details in the the Rider and it successfully updates etc then your unit has been associated with the account. You may see that it has if you open MyDrive connect on the PC without the Rider attached. as it should list the units on your account.

    Doug
  • horkonponhorkonpon Posts: 4 [Apprentice Seeker]
    Hi Doug,
    DougLap wrote: »
    Hi @horkonpon
    (...)
    Regarding adding the device to your account if you have input your account details in the the Rider and it successfully updates etc then your unit has been associated with the account. You may see that it has if you open MyDrive connect on the PC without the Rider attached. as it should list the units on your account.

    Doug

    Thanks for your fast answer.

    In your answer is my problem. Like you say, I have input my account details in the Rider and it successfully updates, I can send routes, etc. But in my account only lists the old TomTom GO 300 and not my new Rider 550.

    My Rider 550 works OK but I'm receiving mails from TomTom to buy a new device (because the old GO300 cannot be updated) that I have bought.

    Alberto
  • DougLapDougLap Posts: 5,569
    Superuser
    Hi @horkonpon

    Normally I would suggest you phone Customer Support but I suspect that is not working at the moment.

    Maybe one of the Mods on here @VikramK or @lampard can sort this out for you. Keep an eye out here.

    Doug
  • tonygrtonygr Posts: 41 [Renowned Wayfarer]
    I suspect the emails are generated by the presence of your old device.

    I have an old XL which is no longer supported and so was given for Christmas a Go Basic which I registered. I still continued to get emails about updating until I cancelled the old device. I think the email generating software is not clever enough to realise that there is a replacement for the outdated device and merely "sees" the old one as needing replacing.
    As to not being able to see the new one have you tried registering it again?
  • YamFazManYamFazMan Posts: 17,064
    Superusers
    edited April 15
    Hi
    @tonygr

    I would assume the Emails are for your old device....
    Scroll to the bottom of the email... Click 'Unsubscribe'
    Follow on-screen instructions to exit....

    gkdbo2kcc49z.jpg
    ATB YFM
  • VikramKVikramK Posts: 9,886 Moderator
    @horkonpon

    Hi Alberto

    Welcome to the community!

    Could you send me the serial number of your device through a private message, please?

    Thank you
    Vikram
  • horkonponhorkonpon Posts: 4 [Apprentice Seeker]
    @VikramK

    Hi Vikram,
    VikramK wrote: »
    @horkonpon

    Hi Alberto

    Welcome to the community!

    Could you send me the serial number of your device through a private message, please?

    Thank you
    Vikram

    I'm sorry for the delay in the response.

    I have sent a private message with the serial number.

    Thank You
    Alberto Miguel
  • horkonponhorkonpon Posts: 4 [Apprentice Seeker]
    Hi all,

    Problem solved. I have my new RIDER 550 in my account and I have removed my old GO 300.

    Thank you all for your help.
    Alberto Miguel
  • DougLapDougLap Posts: 5,569
    Superuser
    Hi @horkonpon

    Glad you are sorted.

    Doug
Sign In or Register to comment.

Who's Online in this Category0