Updating the map on my GO 5200 — TomTom Community

Updating the map on my GO 5200

MLHillsMLHills Posts: 3 [Apprentice Seeker]
My TomTom GO 5200 has the same fault as user eshustrov.
It does not show any maps in the download menu section. The only map on the device was a very old version of Europe map (v975). Also the message appears, that my device is 'up-to-date' , but of course it is not. And after trying and trying I ended up with no maps at all and now and the device is stuck at the 'install map' menu while there are NO maps to choose from...

For me I guess the solution would be 'pushing' the newest software to my 5200, like was done for user eshustrov. Then I can download a map and install updates as I see that this worked very well.

I don't know if MikkoK is still available on this team, but sure would appreciate any help.

Kind regards, Mike

This discussion was created from comments split from: How to update your GO device using Wi-Fi® ?.


  • YamFazManYamFazMan Posts: 18,668
    Welcome to the site....
    The NAV5 (Wi-Fi) devices normally update using Wi-Fi....
    If Wi-Fi is not available or is slow/unstable/unreliable.....
    See Option... (2) Connect over USB....

    TomTom Video... Updating your navigation device using Wi-Fi®

    If you have successfully connected your device to your Wi-Fi....
    To check your Connection Speed, Signal Strength & Quality
    On the Device... Tap 4Dot (.... Menu) --> Settings --> Wi-Fi
    Tap on the Your Wi-fi name (The one Showing as connected)
    A new Menu Page opens

    On the left-hand side of the screen is your Wi-Fi Connection Status

    Tomtom recommend a minimum Wi-Fi download speed of 30Mbps
    Tomtom NAV5 (Wi-Fi) devices will only connect to a 2.4GHz Wi-Fi network
    All the update actions are executed on the device...


    Option... (1) Connected Wi-Fi
    Tap the 4Dot(.... Menu) --> Setting --> Updates & New Items
    Extra Maps are Installed/Maintained... Tap the 4Dot(.... Menu) --> Setting --> Maps

    I always update my devices one Update at a time
    The NavCore Application and QuickFixGPS updates are force ticked by Tomtom... Deselect any other updates like Maps, Speed Cams etc... Update the mandatory item/s first, when complete update the remaining items one at a time

    Note... NAV(5 Wifi) devices connected over Wifi do not require MyDrive Connect to be running Even if myDrive is running you have no access the MyDrive Connect menu structures as used by the previous NAV3 & 4 devices

    Option... (2) Connected USB
    If Wi-Fi is not available or is slow/unstable/unreliable.....
    Tomtom recommend a minimum Wi-Fi download speed of 30Mbps

    Connecting hard-wired over USB is normally more reliable than any Over The Air Connections
    Updating your new device over USB will require "MyDrive Connect"
    Get it here..... https://uk.support.tomtom.com/app/answers/detail/a_id/12428
    Install and Run MyDrive Connect
    There's no need to login to MyDrive Connect... See Note... (1)
    Connect your Device to a USB Port on your PC
    The Update will hopefully complete

    If your using a Laptop it would be also more advisable to use a hard-wire connection back from the Laptop to the Router....

    Note... (1) MyDrive Connect will only show a "Splash screen" saying "Connect your device using Wifi" etc....

    If required you can close the 'Main Mydrive Window' showing the "Connect your device using Wifi" Splash screen... MyDrive Connect only needs to run in the background on the PC TaskBar... The NAV(5 Wifi) devices have no access the MyDrive Menu structures as used by the previous NAV3 & 4 devices
    Updating a NAV5 (Wi-Fi) device using USB is the same as using Wi-Fi, all of the update actions are executed on the device...
    Tap the 4Dot(.... Menu) --> Setting --> Updates & New Items
    Extra Maps are Installed/Maintained... Tap the 4Dot(.... Menu) --> Setting --> Maps

  • MLHillsMLHills Posts: 3 [Apprentice Seeker]
    Thanks you for your reply!

    I read your suggestions very carefully and all of them I did already.
    The problem is, that also connecting via USB does not solve the problem. After some moments I get a message that it is more easier to update via WiFi....
    I even used the software reinstall procedure (at the white text screen pressing 3 times on/off) and then the 5200 seems installing new software, but it keeps installing the same (bad?) version.
    Because I needed route guidance urgently, I bought a new 5200 and that one worked flawlessly. Connecting to WiFi no problem and also updating via USB works very well. This makes me think there is nothing wrong with my PC or home network and that the problem really is the older 5200.
    Playing with the memory card from the new 5200 on the older, ended up with no more maps on the old 5200. And now I have no acces to the menu or anything else. Only the screen where it said in an orange bar: 'No Map Available; you need to add at least one map...'. After pressing the 'Add A MAP' button it brings me to the add-a-map-screen where are NO maps to choose from. It only lists the available disc space.

    In another post I read that there is a possibility that a new version of software (or maybe small map) can be "pushed' to my device by a TomTom technician. Would this be a solution for my poor 5200...?
  • YamFazManYamFazMan Posts: 18,668
    edited March 2020

    1st... See Vikram's Post... (Tomtom Moderator)
    Here... https://discussions.tomtom.com/en/discussion/1121560/tomtom-no-maps-found

    If you have a memory card installed remove it.... The 16GB of on-board should be OK
    You can re-install the Memory Card when you have a Map installed

    2nd... Have you tried a Soft/Drum roll restart on the device ??? This restarts the devices Operating System afresh... You may get access the the Map install menu on the Go 5200
    Tap 4Dot (.... Menu) --> Setting --> Maps --> Add a Map


    Charge the device for at least 2Hrs "OR" have the device plugged into a power supply
    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    I use a Soft/drum-roll start after any upgrade large or small.
    It’s also useful to keep in mind for sorting out most minor niggles....

    3rd Try... Factory reset... You may get access the the Map install menu on the Go 5200
    Check... Tap 4Dot (.... Menu) --> Setting --> System --> Reset Device....
    This will reset the device to as new....
    Note... Myplaces, My Routes, 3rd Party POIs will be deleted from the device and all of the devices Setting reset to defult....

    If you have used the MyDrive Route Planner (Tomtom Cloud) the Myplaces, My Routes, 3rd Party POIs should be restored when you re-sync to the MDW Route planner

    The GO 5200 has World Maps....
    There are many small Maps of only a few MB try installing one of the small maps just to get the device up and running....
    Tap 4Dot (.... Menu) --> Setting --> Maps --> Add a Map

  • MLHillsMLHills Posts: 3 [Apprentice Seeker]

    That was a lot of information and I worked through each section of your Post.
    Point 2 and 3 is now impossible for me to do as I have no access to the 4dots menu anymore. My screen immediately goes to the 'No Maps Available" screen and 'Add A Map' button. And there I can't find any maps to install and stays there.

    However, reading your 1st suggestion (Vikram's Post), make me think that Case 2 is exactly what's wrong with my 5200. It keeps thinking that there is a map installed while there is actually no map, because The Map Certificate Marker is still there and the map is not!!
    This has to be resolved by a technician (as I read further) who can make a script to remove that Marker in the backend, as soon as the device is connected to MyDrive Connect.

    Can you arrange this or do I have to separately contact TomTom for this ?

    Kind regards,

  • YamFazManYamFazMan Posts: 18,668
    edited March 2020

    See Tomtom Video... No Maps Available (Wi-Fi® devices)

    If the above doesn't work @VikramK or @lampard the Forum Moderators should be able to get this sorted in the Morning or notify support to get the problem resolved....

  • VikramKVikramK Posts: 11,097 Moderator
    Hi @MLHills

    I don't find the device linked to your account, could you send me the serial number of your device through a private message ?

  • tollcrosstollcross Posts: 24 [Outstanding Wayfarer]
    I have been trying to update my VIA 1515 for last couple of weeks but no good ..server problem they said...i reinstalled MyDrive connect ...without totally removing old one..still no good....I have a program called Revo uninstaller which is free and it totally removes all remnants of any program you uninstall...I ran it with MyDrive Connect....then reinstalled My Drive Connect....All updates are now working
  • YamFazManYamFazMan Posts: 18,668
    edited April 2020

    Glad you're sorted :)
    On the rare occasions I have a problem with myDrive Connect
    Like you I Delete MyDrive Connect using the free version of Revo Uninstaller then Reinstall MyDrive Connect....
    Using the Method Here... https://discussions.tomtom.com/en/discussion/comment/1682074/#Comment_1682074

    Or... Instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program just as effective for giving MyDrive Connect a CPR...
    See... https://discussions.tomtom.com/en/discussion/comment/1686214/#Comment_1686214

    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.

    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

    "Download/installation interrupted".....
    Are your USB ports set for power saving "USB Selective Suspend"
    See... https://discussions.tomtom.com/en/discussion/comment/1694455/#Comment_1694455
Sign In or Register to comment.

Who's Online in this Category0