tom tom GO 5100 — TomTom Community

tom tom GO 5100

SandyMSandyM Posts: 1 [Apprentice Seeker]
tom tom says device not connected even though device connected to laptop by cable. 5100 GO showing network status not connected
What can i do to fix this please

Answers

  • LAURE123LAURE123 Posts: 1,545 [Revered Voyager]
    edited March 23
    Hi @SandyM

    Maybe a problem with the driver installed by Windows or a firewall lockup.

    Try to do a Soft Reset with your device Connected to your PC by its cable.
    With your device "switch on", press and hold the On/Off button until you hear the drum sounds. This can take 30 seconds or more. The device restarts. If you see a black screen with white text, hold down the button until you hear the drum sounds.

    Our devices are identified as Network Adapters (removable), not USB devices. Check if the TomTom driver is activated.
    With your device Connected to the PC:
    In your PC ==> Right click on the Windows10 "Start button" (or go to Control Panel for W7 and W8) /DeviceManager/Network Adapters/ you must have a "Remote NDIS compatible device" (or "TomTom")/ Right click on it, check if it's activated:
    - If you see the choice "Enable", click on it to activate your driver device.
    - If you see the choice "Disable" it's OK, you have nothing to do.
    - If you found an "unknown device" in "other devices" or a "USB device" with a problem (yellow triangle) removed it.

    Look at this FAQ: "MyDrive Connect does not recognise my device"
    https://uk.support.tomtom.com/app/answers/detail/a_id/21425

    Some firewall (the VPNs too) can block the connexion with MDC. Do an exception for MDC, this file:
    C:\Program Files (x86)\MyDrive Connect\TomTom MyDrive Connect.exe

    Check also if your firewall allows connection with your device, "trusted network".
    If you use the Windows firewall, look at this link "how to do", add TomTom MDC for "private" and "public" network.
    https://www.windowscentral.com/how-troubleshoot-and-fix-windows-10s-firewall-problems#allow_app_windows_firewall

    - - - - - - - - - -

    If it still does not work do a clean installation of My Drive Connect (MDC) with a fresh copy.

    Redo a Soft Reset with your device Not connected to the PC.

    For MyDrive Connect with your device Not connected to the PC:
    1/ Uninstall MDC, accept the removal of downloads in the popup window.
    2/ "Restart" your PC (Not Shut down or Sleep)
    3/ Download and install the last version MDC, take it here:
    - On this page, at the bottom, the green button "Download for ...":
    https://www.tomtom.com/en_gb/mydrive-connect/
    - In the popup window, keep ticked at least "Download updates on my computer (recommended)", the other choices are optional.
    4/ "Log in" with your email and password in MDC.
    5/ Connect your device.

    Regards.
  • torquay33torquay33 Posts: 7 [Apprentice Traveler]
    LAURE123
    Many thanks for your suggestions above which I followed to the letter.
    1. In my device manager it showed the Remote NDIS compatible device #2 had the yellow explanation mark against it and windows cannot verify the digital signature for drivers required. The choices are UPDATE DRIVER, DISABLE DEVICE, UNINSTALL DEVICE. On attempting to update the device it says that Windows has the latest driver installed. I then removed the device, closed down my computer then restarted it. It still showed the yellow explanation mark on rebooting.
    2. I'm using Kaspersky Total Security and in the Network Traffic Monitor, Manage Applications, TomTom International is showing as Green and Network Activity is also shown with a green tick.
    3. I have uninstalled MDC and used CCCleaner to clear out the registry once again and then closed the computer down. I then rebooted and downloaded MDC and installed it once more but the results is still the same.
    4. Doing a soft reset with the cable attached makes no difference and the same applies without the cable attached. On launching the 600 without the cable attached then attaching it and logging into MDC it still does not recognise my GO600.
    5. Still no further forward.
  • LAURE123LAURE123 Posts: 1,545 [Revered Voyager]
    Hi @torquay33

    Sorry :disappointed: , I hadn't seen your answer here. I followed your original topic. Thank you for the more detailed explanations on your problem. I answer you on your own topic here:
    https://discussions.tomtom.com/en/discussion/comment/1702171/#Comment_1702171

    Regards.
Sign In or Register to comment.

Who's Online in this Category0