reset GO 520 WIFI, now wont get past the account login page! — TomTom Community

reset GO 520 WIFI, now wont get past the account login page!

I factory reset my GO 520 wifi as it was no longer updating over WIFI, it just kept saying OOPS....

Since the reset, I have been going through the setup pages one by one, I am now at the TomTom Account page, its asking for my username/password. I enter this and it nearly immediately comes up with
"Oops, we are having trouble accessing the TomTom services. Please try again later"

I have been trying for several hours, no change. Any idea what I can do? :'(

Best Answer

Answers

  • DougLapDougLap Posts: 6,168
    Superuser
    HI @benvk85

    Could you try a soft reset. Ie With the unit on Hold the ON/OFF button in for about 20 seconds plus until you hear the drumroll sound then let the button go and the device will restart.

    Have you input the Wifi details yet whilst setting it up.

    If still a problem then contact Customer support so they can check things at their end especially as it was not updating via your Wifi.

    Australia
    1300 135 604
    Monday-Friday:9:00 am to 5:30 pm AEST

    Don't answer questions but wait for an agent to answer.

    Doug
  • benvk85benvk85 Posts: 3 [New Seeker]
    DougLap wrote: »
    Could you try a soft reset. Ie With the unit on Hold the ON/OFF button in for about 20 seconds plus until you hear the drumroll sound then let the button go and the device will restart.
    I can confirm I have just done the soft reboot, it has loaded up with map centred on my current location. I then try to connect to my drive and the same error comes up as originally reported.

    I have logged out and logged back into my drive on my phone, so I know my username/password are correct.
    DougLap wrote: »
    Have you input the Wifi details yet whilst setting it up.
    yes I did, it said 'connected'

    Cheers

  • GazibarevGazibarev Posts: 95 [Supreme Trailblazer]
    Hi. I have exactly the same problem now. I reset the device to factory settings because there was an error updating through wifi. Now I can't log in again from my device.
  • benvk85benvk85 Posts: 3 [New Seeker]
    Working today, servers must have been down yesterday.
    Thanks for your time.
Sign In or Register to comment.

Who's Online in this Category0