I cannot get my Go premium X to connect to wifi. — TomTom Community

I cannot get my Go premium X to connect to wifi.

When I select settings - wifi It shows my saved wifi setting. If I touch one it says Finding IP address then after a moment or 2 it reverts to Saved. However it is not connecting. I have tried 2 different wifi's but it is the same on both.
I know the wifi is working as my phone is OK and I am sitting right next to my router

Answers

  • YamFazManYamFazMan Posts: 18,474
    Superusers
    edited February 2020
    Hi
    @J_Cattell

    The NAV5 (Wi-Fi) devices like you’re Go premium X
    Normally update using Wi-Fi......See Option... (1)
    But you can update over USB... See Option... (2)


    TomTom Video... Updating your navigation device using Wi-Fi®



    If you have successfully connected your device to your Wi-Fi....
    To check your Connection Speed, Signal Strength & Quality
    On the Device... Tap 4Dot (.... Menu) --> Settings --> Wi-Fi
    Tap on the Your Wi-fi name (The one Showing as connected)
    A new Menu Page opens

    7g8gwfpx1swt.jpg
    On the left-hand side of the screen is your Wi-Fi Connection Status

    Tomtom recommend a minimum Wi-Fi download speed of 30Mbps
    Tomtom NAV5 (Wi-Fi) devices will only connect to a 2.4GHz Wi-Fi network
    All the update actions are executed on the device...

    ___________________________

    If Wi-Fi is not available or is slow/unstable/unreliable.....
    See Option... (2) Connect over USB
    ___________________________

    Option... (1) Connected Wi-Fi
    Tap the 4Dot(.... Menu) --> Setting --> Updates & New Items
    Extra Maps are Installed/Maintained... Tap the 4Dot(.... Menu) --> Setting --> Maps

    I always update my devices one Update at a time
    The NavCore Application and QuickFixGPS updates are force ticked by Tomtom... Deselect any other updates like Maps, Speed Cams etc... Update the mandatory item/s first, when complete update the remaining items one at a time

    Note... NAV(5 Wifi) devices connected over Wifi do not require MyDrive Connect to be running Even if myDrive is running you have no access the MyDrive Connect menu structures as used by the previous NAV3 & 4 devices

    Option... (2) Connected USB
    If Wi-Fi is not available or is slow/unstable/unreliable.....
    Tomtom recommend a minimum Wi-Fi download speed of 30Mbps
    Updating your new NAV5 (Wi-Fi) device over USB will require "MyDrive Connect"
    Get it here.....
    www.tomtom.com/getstarted
    Run MyDrive Connect.....
    Note... The NAV(5 Wifi) devices have no access the MyDrive Menu structures as used by the previous NAV3 & 4 devices
    Connect your Device to a USB Port on your PC
    Updating a NAV5 (Wi-Fi) device using USB is the same as using Wi-Fi, all of the update actions are executed on the device...
    Tap the 4Dot(.... Menu) --> Setting --> Updates & New Items
    Extra Maps are Installed/Maintained... Tap the 4Dot(.... Menu) --> Setting --> Maps
    __________________________

    Note... MyDrive Connect will only show a "Splash screen" saying "Connect your device using Wifi" etc
    If required you can close the 'Main Mydrive Window' showing the "Connect your device using Wifi" Splash screen... MyDrive Connect only needs to run in the background on the PC TaskBar


    27bxc59f2s23.png
    ATB YFM
  • DougLapDougLap Posts: 6,924
    Superuser
    Hi @J_Cattell

    If you set the connection up to your Home Wifi and it connects on setup then when you turn the GO Premium on when at home it should select that Wifi connection unless you have your Phones Hotspot set up as well in which it might select that.

    It I have my Home Wifi set up and my iPhones Hotspot set up then when I turn my GO unit on it usually connects to the Wifi and says the Hotspot is saved. If I want to switch to the Hotspot then when I tap the Hotspot I get the option to Connect then it switches too it. If I want to switch back to my Wifi then the Finding IP address appears but it then goes to Connected.

    Try a Soft Reset. Ie with the Premium on and working Hold the ON/OFF button down for about 20 seconds plus until you hear the Drumroll sound then let the button go and see if that sorts it.

    Doug
Sign In or Register to comment.

Who's Online in this Category0