Cant run MyDrive Connect on Windows 10 — TomTom Community

Cant run MyDrive Connect on Windows 10

peteratukhotpeteratukhot Posts: 15 [Apprentice Traveler]
edited February 2020 in MyDrive Connect
I have run the latest installer of TomTom's MyDrive Connect app on Windows 10.
The app appears to install but will not run or display.
When starting the app, the mouse pointer shows busy for a few seconds then, nothing!
Task Manager shows that the app is apparently running and using about 1.8mb but there is no user interface displayed on screen! The only way to stop the app is through task manager.
When trying to uninstall the app using the built-in uninstaller it appears to hang on "TomTomCacheCleanup.exe" and never progresses to the end. The only way to uninstall the app has been to use a third-party uninstaller (Revo Uninstaller).
I have tried all the usual fixes i.e. re-downloads, uninstalls/reinstalls, running in compatibility modes and different graphic settings, I have checked security properties etc and even tried to run it in Safe Mode, all to no effect!
The app worked perfectly well on my previous Windows 7 installation.
I would be very grateful for any help or suggestions as I am now unable to update my SatNav.
Thanks.

Answers

  • rider1riderrider1rider Posts: 350 [Supreme Pioneer]
    runs okay on my windows 10 pc. did you try to run the program as a administrator? sometimes it could just be a computer related issues but you can confirm this with the customer care at tomtom.
  • peteratukhotpeteratukhot Posts: 15 [Apprentice Traveler]
    Hi, Thanks for your reply.
    Yes, have tried running as administrator and all kinds of other first-response type solutions. It may well be computer related as I have now found this same problem with at least one other app. I have only just recently "upgraded" from my previous Windows 7 OS, so I am thinking somehow it may be a conflict with old settings not updating or adapting, though I have tried several registry scans and cleans.
    Not sure I'll get much help from TomTom support, so far I have been unable to make contact with them (and from what I read from others they may not be much use anyway). :-(
Sign In or Register to comment.

Who's Online in this Category0