Unable to access TomTom Services — TomTom Community

Unable to access TomTom Services

JamieTaylorJamieTaylor Posts: 2 [Apprentice Seeker]
Hi,

I have a TomTom Go 500 and have been using it fine for a few years. Now, despite updating it regularly it is refusing to access the TomTom services - so I have no live traffic!

I have reset my device to Factory Reset and then re-downloaded everything to see if this helps, but no, it still says "Oops we are having trouble accessing TomTom services, please try again later." So I have lost all my saved places for nothing!

Later has so far been 3 weeks!!!

This is frankly getting ridiculous now and reaching the point of just buying something from Garmin or other manufacturer as I need something reliable for work...

Does anyone on here know of a recurring problem TomTom are trying to fix or a guaranteed way of resolving this?

Thank you in advance.

Answers

  • DougLapDougLap Posts: 7,966
    Superuser
    Hi @JamieTaylor

    Have you fully deleted the my Drive Connect software and reloaded from the Tomtom website If not then I suggest you try that and use the Revo Uninstall software available on the Net to ensure all traces are removed. If you look through this forum and use the search option at the top of this page by putting Revo in the search you will see some more information on what to do.

    Doug
  • JamieTaylorJamieTaylor Posts: 2 [Apprentice Seeker]
    Thanks @DougLap for the assistance.

    Unfortunately I have done this in full and the problem still persists. I have updated all the desktop software and factory reset my TomTom device again before connecting it all up and starting from scratch.

    Whenever I try to set-up the TomTom Services it just keeps coming back with the same message on the device of "Oops we are having trouble accessing TomTom services, please try again later."
  • DougLapDougLap Posts: 7,966
    Superuser
    Hi @JamieTaylor

    Try Customer Support.

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

    Doug
  • chrisocschrisocs Posts: 10 [Master Explorer]
    I discovered similar problems an finaly found the solution.
    Use the mobile phone as an access point for WIFI connection, and not mailing Bluetooth connection between GPS and phone.

    Make sure the access point is activated BEFORE powering-up (or restarting) the TomTom
Sign In or Register to comment.

Who's Online in this Category0