520 and 620 freezing — TomTom Community

520 and 620 freezing

Anyone had trouble with the tomtom freezing and going black screen several times then restarting when connected to traffic. I have done the factory reset and the reset where you press the power button 3 times and still will not work. Works great if you switch the traffic off but driving 300+ miles a day I need it. Even tried bluetooth tethering and still no joy.
Any ideas guys

Comments

  • rider1riderrider1rider Posts: 63 [Supreme Trailblazer]
    you report to have the same problem with two devices.. have you tried a different usb cable or the charging adapter. also check with your car service point to find if the charging socket had developed some fault..

    or may be just test the device on a different car with a new cable and charger adapter.
  • LkershyLkershy Posts: 7 [Apprentice Seeker]
    Thank you for your reply Rider. Yes I ave tried in 2 separate vehicle's with 3 different cables and 3 different docking stations. I feel it was the latest update that causes issue as updated both. Funny thing is you can drive 70 miles with no problem then all of a sudden it starts locking up.
  • DougLapDougLap Posts: 3,961 Superuser
    Hi @Lkershy

    Just to clarify are you using the Cig Charger that came with the Devices or are you plugging the cable into a USB socket in the cars. The latter will not give enough power to charge the device and run it as well so the battery will start to struggle after a while.

    Doug
  • LkershyLkershy Posts: 7 [Apprentice Seeker]
    Hi Doug
    Yes I am using the cig lighter socket and the tomtom charger on both vehicles. The 620 is less that 2 weeks old and is a replacement for 1 I sent back with same issues
  • DougLapDougLap Posts: 3,961 Superuser
    Hi @Lkershy

    It seems very odd that you have now had 3 units all demonstrating the same problem.

    Have you checked the CiG socket on the car is not loose. There are some vehicle models where some have noted a problem with the socket not retaining the TT charger socket properly. Unless the 2 vehicles you tried were the same model this seems unlikely.

    Doug
  • LkershyLkershy Posts: 7 [Apprentice Seeker]
    Hi Doug
    1 it a 17 plate ford jumbo van and the other is 18 plate alfa.
    Also to add have same problem trying to update at home. Sure it's the traffic connection as if I switch it off they both work fine but drive 300 miles plus a day so realĺy need the traffic function.
  • VikramKVikramK Posts: 8,784 TomTom Moderator
    Hi @Lkershy

    Do you have both devices set up on the same account? Could you try using a different account as this could be because of the synch issue with MyDrive?

    Thanks
    Vikram
  • LkershyLkershy Posts: 7 [Apprentice Seeker]
    Hi Vikram

    You may be right as TomTom have just replied and said do a factory reset followed by a soft reset then login using a test email account. Will keep you updated.
    Thanks all
  • LkershyLkershy Posts: 7 [Apprentice Seeker]
    Finally sorted the problem after a lot of emails to TomTom.
    They have admitted they have a problem with the my drive sync so all I have to do is stop sync. They have told me quite a few customers have had the same problem and hope to sort it in new update
  • YamFazManYamFazMan Posts: 15,791 Superusers
    Hi
    @Lkershy
    Logging out of MyDrive on your devices is the way to go....
    When you need to sync a route file, log back into MyDrive on the device/s you wish to sync the data
    I use this method with 8 devices... After all, you only need to enter the password, the device remembers the email address....
    See... https://discussions.tomtom.com/en/discussion/comment/1668483/#Comment_1668483
    _________________________

    Also... I find the NAV5 (Wi-Fi ) devices are more stable in general use if you Turn off the Wi-Fi and only connect the Wi-Fi when any updates are required

    To forget the Wi-fi on the device....
    You can't actually turn-off the Wi-Fi but you can forget it, the device will still be monitoring for a Wi-Fi service but not Connecting & Syncing....
    Tap 4Dot (.... Menu) --> Setting --> Wi-Fi... Tap on your Wi-Fi's Name (Screen top left)
    Tap Modify --> Forget
    Follow on-screen instructions to finish

    ATB YFM
Sign In or Register to comment.

Who's Online in this Category0